Defect #4239

Issue view is not displayed correctly in Google Chrome 4

Added by ChunChang Lo almost 10 years ago. Updated about 9 years ago.

Status:ClosedStart date:2009-11-18
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:UI
Target version:-
Resolution:No feedback Affected version:

Description

Please see the attached images.

There is a huge empty area in the Google Chrome browser. Don't know whom should be accused of.

firefox-issue-view.png - normal issue view in Mozilla Firefox (62.5 KB) ChunChang Lo, 2009-11-18 08:02

chrome-issue-view.png - abnormal issue view in Google Chrome (67 KB) ChunChang Lo, 2009-11-18 08:02

History

#1 Updated by Kamil . almost 10 years ago

This one happens only with Gravatars

#2 Updated by Mischa The Evil almost 10 years ago

I'm not able to reproduce this error with Redmine 0.8.7-devel@r3076 and Google Chrome 3.0.195.33 with or without gravatars enabled.
Which versions are you using?

#3 Updated by ChunChang Lo almost 10 years ago

I forgot that I am using the bleeding edge version from Dev Channel. Sorry for not mentioning this.

In order to clarify this issue, I have tried the most recent versions in the stable, beta and dev channels. And the results are as follows:
  • stable (3.0.195.33) - issue doesn't exist.
  • beta (4.0.223.16) - issue exists.
  • dev (4.0.249.0) - issue exists.
    Hope this will help.

#4 Updated by Nanda P over 9 years ago

I have the same issue with Google Chrome 4.0.223.16, Only when "Use Gravatar user icons" is On.

#5 Updated by Jean-Philippe Lang over 9 years ago

We'll see with the final version of Chrome 4.

#6 Updated by Caius Durling over 9 years ago

I'm seeing this issue in the Webkit nightlies too. So at a guess it's something in newer versions of webkit, hence only in (Safari) Webkit.app nightly's and dev channel Chrome.

Turning Gravatars off fixes the issue for me, running Webkit.app "Version 4.0.4 (6531.21.10, r51075)" and Redmine "Redmine 0.8.0.devel" according to the information page, which is actually 0.8.4, commit fa4fb5f4cabb947ceec59d14da0f0191602b21d1 according to git.

#7 Updated by Henrik Ammer over 9 years ago

Notice that the bug does not show up if you use for instance the Squeejee or Basecamp theme therefor it's a CSS problem.

Somewhere between the p.author and the table.attributes something is different but haven't found a clue (yet) what it might be that differs between the standard/alternate/classic theme and the two mentioned above.

Tested on Chrome 4.0.223.16.

#8 Updated by Mischa The Evil over 9 years ago

  • Subject changed from Issue view is not displayed correctly in Google Chrome to Issue view is not displayed correctly in Google Chrome 4

#9 Updated by Soen Trueman over 9 years ago

I just wanted to add a quick note for those looking for a temporary solution; If you comment out the following in the application.css, the space disappears:

img.gravatar { 
    /*padding: 2px;
  border: solid 1px #d5d5d5;*/
  background: #fff;
}

div.issue img.gravatar {
    float: right;
    margin: 0 0 0 1em;
    /*padding: 5px;*/
}

I've tested this in Chrome (Dev Channel) 4.0.249.11 on Windows.

HTH.

#10 Updated by Kai Krakow over 9 years ago

I've got the same problem and commenting out the parts of the css from comment #9 does not fix it for me in chromium 4.0.260.0, neither in aurora (also webkit-based). However replacing float:right with position:absolute and setting right:240px fixes this huge spacing. But of course it also moves the small gravatar icon out of its normal place, so this solution is undesirable.

I consider this a rendering bug in webkit as it absolutely makes no sence to render this huge space when looking at the css. It should maybe be reported to the webkit developers to be tracked here. The title should be changed to "Issue view is not displayed correctly in Webkit v532.5" because it affects other webkit-based browsers, too. This is what my chromium versions say about component versions:

Chromium    4.0.260.0 (Entwickler-Build 33405)
WebKit      532.5
V8          2.0.2.1
User Agent  Mozilla/5.0 (X11; U; Linux i686; en-US) AppleWebKit/532.5 (KHTML, like Gecko) Chrome/4.0.260.0 Safari/532.5

#11 Updated by Kai Krakow over 9 years ago

BTW: Taking away the legacy width="100%" attribute from the table below the image completely solves the huge space. Still it is a rendering bug of webkit which should be reported. Also this makes the table smaller as intended because the image takes available space from it then.

#12 Updated by Alex Bevilacqua over 9 years ago

Soen Trueman wrote:

I just wanted to add a quick note for those looking for a temporary solution; If you comment out the following in the application.css, the space disappears:

[...]

I've tested this in Chrome (Dev Channel) 4.0.249.11 on Windows.

HTH.

Having the same issue under chromium [4.0.266.0 (Ubuntu build 33943)] and just want to confirm that the css hack here does address the spacing issue ... though it's obviously just meant as a stop-gap solution :P

#13 Updated by Rémy Hubscher over 9 years ago

Same problem here with Google Chrome 4.0.249.30

#15 Updated by ChunChang Lo over 9 years ago

it seems that this issue gets fixed in 4.0.266.0 version of google chrome.

#16 Updated by Chuck Battle over 9 years ago

ChunChang Lo wrote:

it seems that this issue gets fixed in 4.0.266.0 version of google chrome.

Not for me.

#17 Updated by Chuck Battle over 9 years ago

Chrome version 4.0.288.1 dev Does correct this display issue for me in XP.

#18 Updated by ChunChang Lo over 9 years ago

  • Status changed from New to Resolved

Josh Galvez wrote:

Reported to Webkit here: https://bugs.webkit.org/show_bug.cgi?id=32690

This should be fixed in the current (stable, beta, development) versions of Google chrome.

#19 Updated by Josh Galvez over 9 years ago

It's working for me now.

#20 Updated by Robin McKenzie over 9 years ago

Not working for me in Google Chrome 4.1.249.1021 beta (40167)

#21 Updated by Robert Lankford about 9 years ago

Updated by Soen Trueman 6 months ago

I just wanted to add a quick note for those looking for a temporary solution; If you comment out the following in the application.css, the space disappears:

img.gravatar { 
    /*padding: 2px;
  border: solid 1px #d5d5d5;*/
  background: #fff;
}

div.issue img.gravatar {
    float: right;
    margin: 0 0 0 1em;
    /*padding: 5px;*/
}
I've tested this in Chrome (Dev Channel) 4.0.249.11 on Windows.

HTH.

You were absolutely correct. Thanks so much for posting this!!

#22 Updated by Felix Schäfer about 9 years ago

This seems to be working on recent chrome versions, can anyone confirm that this is gone on current stable chrome? Thanks.

#23 Updated by Felix Schäfer about 9 years ago

  • Status changed from Resolved to Closed
  • Resolution set to No feedback

Also available in: Atom PDF