Defect #4243

{{include}} macro mangles HTML entities in <pre> blocks

Added by Chris Miller about 8 years ago. Updated almost 6 years ago.

Status:ClosedStart date:2009-11-19
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Wiki
Target version:-
Resolution:Cant reproduce Affected version:0.8.6

Description

Use of the include macro garbles HTML entities (specifically < and > characters that I noticed).

Steps to repeat:

1) Create an wiki page (of awesomeness)

blah blah blah stuff about the page

<pre><code class="c">
FSLPoint p; FSLPoint o; o.x = 0; o.y = 0;
FSLPoint s; s.x = 7; s.y = 7;
for(p.x=0; p.x<8; ++p.x)
    for(p.y=0; p.y<8; ++p.y)
        board[FSLPointVectorize(&p, &o, &s)] = 0;
</code>

2) use the include macro to include that page from another page

{{include(mypage)}}

In the page that did the including, the < character shows up as &lsaquo; but on the original page it shows up just fine.

First observed at FSPoint_vectorizationGuide and FSPoint_vectorizeWithOrigin_size as well as FSLPoint_Vectorize.

I think the include macro is washing the page through the HTML entities engine one too many times, but I can't be sure.

History

#1 Updated by Oskar Nordquist about 8 years ago

Does anyone have a fix for this? I'd really appreciate a quick and dirty hack that solves this problem.

#2 Updated by Mikhail Grinfeld over 7 years ago

I have same issue:

I created template with

  <pre>
    <some xml>
  </pre>

when I included it in other page, I found
    &lt;some xml&gt;

I have redmine 0.9.2

#3 Updated by Alvaro Herrera over 7 years ago

I have the same issue, though my problematic char of choice is & -- it gets escaped as &

#4 Updated by Etienne Massip almost 6 years ago

  • Resolution set to Cant reproduce

Seems that it has been fixed, I can't reproduce?

#5 Updated by Mischa The Evil almost 6 years ago

Etienne Massip wrote:

Seems that it has been fixed, I can't reproduce?

Me neither...

#6 Updated by Etienne Massip almost 6 years ago

  • Status changed from New to Closed

Also available in: Atom PDF