Feature #4396

Ask user to confim exiting unsaved wiki page

Added by Tiago Alves almost 8 years ago. Updated almost 8 years ago.

Status:ClosedStart date:2009-12-14
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:-
Target version:-
Resolution:Duplicate

Description

I just lost a great deal of documentation I was writing on a project's wiki because I accidentally loaded another webpage in the same tab. Hitting the back button didn't help as it just reloaded the edit page with the last saved wiki entry.

I'd like to request a feature enhancement which is a pop up that requests the users to confirm if they really want to load another page or close the current tab/window if there's unsaved text during wiki edits. I guess it can be done with window.onbeforeunload().

Another solution could be to auto-save wiki edits periodically to some kind of draft section like Gmail does.

PS: I know I should save my edits periodically but I don't like to see a lot of edits in the wiki history.


Related issues

Duplicates Redmine - Feature #2910: Warning on leaving edited issue/wiki page without saving Closed 2009-03-05

History

#1 Updated by Mischa The Evil almost 8 years ago

  • Status changed from New to Closed
  • Resolution set to Duplicate

Closed as a duplicate of #2910.

Also available in: Atom PDF