Feature #4398

Author Issue-filter only contains members even when non-members have 'create issue' permission

Added by Mischa The Evil almost 8 years ago. Updated almost 2 years ago.

Status:ClosedStart date:2009-12-14
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Issues
Target version:-
Resolution:Duplicate

Description

From Eric Davis over IRC:

if non-members are allowed to create issues, Issue Filters > Author should list non-members too


Related issues

Duplicates Redmine - Feature #1875: Issue filtering on author only uses members of project New 2008-09-09

History

#1 Updated by Jean-Philippe Lang almost 8 years ago

We can not list all users in this field, we need to change this filter to an auto-complete field first.

#2 Updated by Mischa The Evil almost 8 years ago

Jean-Philippe Lang wrote:

We can not list all users in this field (...)

Agreed! :)

#3 Updated by Nick Fitzgerald almost 8 years ago

+1
Just discovered this issue myself.

#4 Updated by Eric Davis almost 7 years ago

  • Assignee deleted (Eric Davis)

#5 Updated by Etienne Massip over 6 years ago

  • Target version set to Candidate for next major release

#6 Updated by Gabriel Mazetto over 4 years ago

Any update on this? We should consider it a defect rather then a feature... as the expected behaviour is currently not being matched by the actual code.

#7 Updated by Toshi MARUYAMA almost 2 years ago

  • Status changed from New to Closed
  • Target version deleted (Candidate for next major release)
  • Resolution set to Duplicate

I close as duplicate of #4398.

#8 Updated by Toshi MARUYAMA almost 2 years ago

Toshi MARUYAMA wrote:

I close as duplicate of #4398.

Sorry, it is #1875.

#9 Updated by Toshi MARUYAMA almost 2 years ago

  • Duplicates Feature #1875: Issue filtering on author only uses members of project added

#10 Updated by Alexey Poliansky almost 2 years ago

173c177,183
<     author_values += users.collect{|s| [s.name, s.id.to_s] }
---
>    if project 
>      project.issues.group(:author_id).each{|i| author_values << [i.author.name, i.author_id.to_s]}
>      else
>      author_values += users.collect{|s| [s.name, s.id.to_s] }
>      end

Add only authors to filter list, if neccessary.
not contain subprojects yet, but it's also possible

#11 Updated by Alexey Poliansky almost 2 years ago

I select all authors from issues in last half of year and preload authors objects

173c174,182
<     author_values += users.collect{|s| [s.name, s.id.to_s] }
---
>    if project 
>       time_range = (Time.now - (3600*24*180))..(Time.now)
>       author_values += project.issues.where(issues: { created_on: time_range }).group(:author_id).preload(:author).collect{|s| [s.author.name, s.author_id.to_s]}
>      author_values.sort!
>      else
>      author_values += users.collect{|s| [s.name, s.id.to_s] }
>      end

works fast and useful for control workflow projects

Also available in: Atom PDF