Feature #4403

Copy with related task

Added by Alain V. over 4 years ago. Updated about 1 year ago.

Status:ClosedStart date:2009-12-15
Priority:NormalDue date:2013-04-17
Assignee:-% Done:

0%

Category:Issues
Target version:-
Resolution:

Description

In our way of working in our company, when we get a ticket on our software from the customer that we consider as bug, we copy it to the validation project for debugging.
The option copy of a task is nice for that, but would it be possible to create also automatically the related task.
So for us for a bug in our validation project we would know this one comes from a customer and not from our validation process.
Thank you

implement_custom_copies.patch Magnifier - implementation of custom copies (missing creation UI) (6.08 KB) James Bernard, 2009-12-21 02:57

0100-adstec-copy_and_relate.patch Magnifier - patch copy and relate (2.09 KB) Karl-Heinz Nirschl, 2010-05-05 14:44

copy_to_another_project_and_relate.patch Magnifier (1.75 KB) Paul Preece, 2010-06-07 13:28

ro4403-copy_improvements.patch Magnifier - Patch created against trunk @ r7630. (5.18 KB) Mischa The Evil, 2011-10-20 22:26

ro4403-copy_improvements.jpg - Screenshot of the patched feature. (31.6 KB) Mischa The Evil, 2011-10-20 22:26


Related issues

Related to Patch #7447: Patch for improved move/copy New 2011-01-25
Related to Patch #7586: Create "related to" relationship during issue copying Closed 2011-02-09
Related to Feature #6899: Add a relation between the original and copied issue Closed 2010-11-15
Related to Feature #1701: New Relation for Copying Branch Issues to other Versions Closed 2008-07-28
Duplicated by Defect #8863: Task copy bug Closed 2011-07-20

History

#1 Updated by Jean-Philippe Lang over 4 years ago

Do you mean automatically adding a relation between the original issue and the copied issue, so that the copied issue is related to the original issue?

#2 Updated by Alain V. over 4 years ago

Jean-Philippe Lang wrote:

Do you mean automatically adding a relation between the original issue and the copied issue, so that the copied issue is related to the original issue?

Exactly Jean-Philippe!

but not necessary automatically. Maybe be optionnal in the copy window or configurable.

#3 Updated by Mischa The Evil over 4 years ago

Alain V. wrote:

Jean-Philippe Lang wrote:

Do you mean automatically adding a relation between the original issue and the copied issue, so that the copied issue is related to the original issue?

Exactly Jean-Philippe!

but not necessary automatically. Maybe be optionnal in the copy window or configurable.

+1 on such a feature. But I personally think that it's best to make it indeed optional through e.g. a checkbox on the issue copy-view. Maybe a new issue-relation type would be best too? One like "Copied" or "Branched"? Any thoughts?

#4 Updated by James Bernard over 4 years ago

I wrote a patch that addresses that request

This patch implements what I call "custom copies" which are standard copies but with all settings automatically set, so that only one click is needed. "Related to" relation is also automatically set between the copied issue and its copy.

A custom copy defines a source issue by its project/tracker/status and the target issue by its project/tracker/status. In addition, it is possible to define a new status for the source issue once the copy is done.
Custom copies also have a label. When an issue is shown, only custom copies whose source issue criteria is matching the shown issue are displayed in the issue toolbar, beside usual Update/Move/Copy/Delete links.

Example: a custom copy labelled "confirm as bug" defining automatic copy from Hotline/Hotline/New to Validation/Bugs/New, with automatic change of Hotline/Hotline/New to Hotline/Hotline/Confirmed as bug after the copy.

Note: The patch does not include a form for creating custom copies. As of now, I'm creating them through SQL command...
Moreover I'm really a newbie in Ruby/Rails/Redmine world so the code is probably quite poor/wrong in some areas, I'm just providing the patch as an example of design...

#5 Updated by Bill Tihen over 4 years ago

This patch seems VERY useful. We have over 200 users who submit tickets -- it would be GREAT if we had a "ME TOO" feature! That then created a related task (but not the regular relationship) -- we already use the regular relationship for related, but different tasks.

Also if a different relationship (a copied from or a "me too" relationship is available -- then that could be optionally extended so that we could manage one request and have all tasks reflect the changes made to the master task.

#6 Updated by Alain V. over 4 years ago

Bill Tihen wrote:

This patch seems VERY useful. We have over 200 users who submit tickets -- it would be GREAT if we had a "ME TOO" feature! That then created a related task (but not the regular relationship) -- we already use the regular relationship for related, but different tasks.

Also if a different relationship (a copied from or a "me too" relationship is available -- then that could be optionally extended so that we could manage one request and have all tasks reflect the changes made to the master task.

A ME TOO is not like a vote?
Like me too i would like this feature?

#7 Updated by Alain V. over 4 years ago

JP, it is not possible to put this in the version 1.0? I think this would help a lot of people. :o)

#8 Updated by Karl-Heinz Nirschl about 4 years ago

Hi,

i did an other patch, which just extends the copy and move dialog so that one could add a relation in one step. this is done for 0.9.3.

let me know if i should improve the code so it could be pushed to 1.0.

#9 Updated by Paul Preece about 4 years ago

Here's another patch with test against trunk.

We would certainly find this useful in a release.

#10 Updated by Pedro Gutierrez about 4 years ago

+1
I hadn't found this feature request and had, so, opened a similar one #5497

#11 Updated by Brian Lindahl over 3 years ago

see patch #7447

#12 Updated by Etienne Massip almost 3 years ago

  • Target version set to Candidate for next major release

#13 Updated by Mischa The Evil almost 3 years ago

I've extracted the relationship addition on copy > new from Brian Lindahl's patch in #7447, rebased it to source:/trunk@7630 and added two new relationtypes (copied to / copied from) to support the issue-copy relationship completely.

Screenshot of the patched feature.

Any feedback is appreciated...

#14 Updated by Radek Karban about 2 years ago

+1

#15 Updated by Michael Jurisch over 1 year ago

Thanks a lot for that feature, but unfortunately defining the relation just work for tickets, that are copied within the same project, but I would need setting the relationship between a ticket in project A and its copied counterpart in project B.

Thanks in advance!

#16 Updated by Mischa The Evil over 1 year ago

Michael Jurisch wrote:

[...] but unfortunately defining the relation just work for tickets, that are copied within the same project, but I would need setting the relationship between a ticket in project A and its copied counterpart in project B.

Shouldn't this be already possible by setting "Allow cross-project issue relations" to true combined with the implementation in r10491 for #6899 (2.2.0)?

Edit: in fact, it looks like this whole issue has been superseded by #6899. Could someone test this feature in recent Redmine version?

#17 Updated by Mischa The Evil over 1 year ago

  • Due date set to 2013-04-17
  • Status changed from New to Needs feedback

#18 Updated by Michael Jurisch over 1 year ago

Hey, Mischa, thanks a lot for that hint! I completely missed that option. :-( I am sorry!

This works perfect in Redmine 2.2.3.stable! Thanks!

#19 Updated by Daniel Felix about 1 year ago

  • Status changed from Needs feedback to Closed

This one could be closed as there is user Feedback in note 18.

Thanks for your feedback.

#20 Updated by Toshi MARUYAMA about 1 year ago

  • Target version deleted (Candidate for next major release)

Also available in: Atom PDF