Feature #4582

Automaticly set an issue status when an issue is first assigned

Added by Jean-Jacques Mérillon over 9 years ago. Updated over 9 years ago.

Status:NewStart date:2010-01-14
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Issues
Target version:-
Resolution:

Description

Automaticly set issue status to Assigned when the issue is New and assigned to change from EMPTY to SOMEONE

See note 5 for the new suggestion.


Related issues

Related to Redmine - Patch #640: When choosing assignee, automatically switch status to As... New 2008-02-12
Related to Redmine - Feature #2128: Problems when 'Assigned To' field doesn't match 'Assigned... New 2008-11-03
Duplicated by Redmine - Feature #349: New product, assign task to someone should set status to ... Closed
Duplicated by Redmine - Feature #7124: Assigning an Assignee should change the issue status Closed 2010-12-17

History

#1 Updated by Felix Schäfer over 9 years ago

I'd flag this as a bad idea: say the "assigned to" field is filled according to "category" or anything else, and that assignee is head of a department in charge of assigning it to someone in said department, automatically setting the "status" field to "assigned" would then be false information, as said person is not in charge of the actual implementation but of assigning the ticket to someone.

#2 Updated by Elliot Winkler over 9 years ago

I think status should definitely be set to Assigned automatically. I'm not sure why it hasn't been like that all along. It's kind of annoying to have to remember to set two things when you want to assign the issue to somebody.

Re: Felix's case, I wonder if that's really all that common. Besides, if you assign it to somebody who will assign it to someone else, technically, the issue's been looked at and assigned to someone, right? It's just that the work hasn't begun yet (but you should really have another status that you set manually if you want to track that information). Even so, I guess there should probably be a configuration option in the backend to disable auto-assigning (it could be enabled by default).

#3 Updated by Jeffrey Jones over 9 years ago

I have to agree with the original issue and Elliot Winkler.

To me, and the other people using the software here. The "Assigned to" field translates to "If you need something done on this issue then talk to this person"

To use Felix's example: If an issue is assigned to a manager (via the category field) who hasn't assigned it to a developer then I need to bug the manager to do his thing so that the bug can be progressed.

To us a "New" issue is an issue that no one has looked at yet and can't be automatically assigned (via categories for example) so requires someone to actively intervene.

#4 Updated by Mischa The Evil over 9 years ago

Elliot Winkler wrote:

I think status should definitely be set to Assigned automatically. I'm not sure why it hasn't been like that all along. It's kind of annoying to have to remember to set two things when you want to assign the issue to somebody.
[...]

The status "Assigned" won't be available out of the box in Redmine 0.9.0. See issue #3605.

#5 Updated by Jeffrey Jones over 9 years ago

Can we have a more flexible solution then (more work though).

In the issue statuses we currently have a default "start" status. Would it be possible to set a default status that should be selected when the assigned_to field is first populated.

Have some JS on the issues page that will set the status accordingly when the assigned_to field is populated and the issue is currently on the default start status. A very crude state-machine if you will.

#6 Updated by Eric Davis over 9 years ago

  • Subject changed from Automaticly set status to Assigned to Automaticly set an issue status when an issue is first assigned
  • Category changed from UI to Issues

Mischa is correct, #3605 renamed the default "Assigned" status to "In Progress".

I've reword the subject to describe setting a status when an issue is first assigned.

#7 Updated by Go MAEDA about 3 years ago

  • Related to Feature #349: New product, assign task to someone should set status to "Assigned" added

#8 Updated by Go MAEDA about 3 years ago

  • Related to deleted (Feature #349: New product, assign task to someone should set status to "Assigned")

#9 Updated by Go MAEDA about 3 years ago

  • Duplicated by Feature #349: New product, assign task to someone should set status to "Assigned" added

#10 Updated by Go MAEDA about 3 years ago

  • Duplicated by Feature #7124: Assigning an Assignee should change the issue status added

#11 Updated by Go MAEDA about 3 years ago

  • Related to Patch #640: When choosing assignee, automatically switch status to Assigned added

#12 Updated by Toshi MARUYAMA almost 3 years ago

  • Related to Feature #2128: Problems when 'Assigned To' field doesn't match 'Assigned' issue tracker added

Also available in: Atom PDF