Feature #4962

"Hide my email address" enable by default

Added by Thomas NOEL almost 8 years ago. Updated over 1 year ago.

Status:ClosedStart date:2010-03-02
Priority:LowDue date:
Assignee:-% Done:

0%

Category:Accounts / authentication
Target version:-
Resolution:Duplicate

Description

By default, redmine disable the "Hide my email address" option.

IMHO it would be better to hide the email address by default. Or, if possible, to have an option in the authentication settings ("hide emails by default for new accounts ?").

I do not know enough about Ruby to help you with a patch proposal... sorry.


Related issues

Related to Redmine - Feature #707: Hide email address from unregistered users New 2008-02-21
Duplicates Redmine - Feature #21042: Check "Hide my email address" by default for new users Closed

History

#1 Updated by Jean-Philippe Lang almost 8 years ago

  • Tracker changed from Defect to Feature

#3 Updated by Kirill Kornyakov over 5 years ago

  • Status changed from New to Resolved

#4 Updated by Craig Rodrigues over 4 years ago

This issue is not resolved. Can the Redmine admins instead
tag this as a duplicate of #707

#5 Updated by Toshi MARUYAMA about 4 years ago

  • Status changed from Resolved to New

#6 Updated by Go MAEDA over 1 year ago

  • Duplicates Feature #21042: Check "Hide my email address" by default for new users added

#7 Updated by Go MAEDA over 1 year ago

  • Status changed from New to Closed
  • Resolution set to Duplicate

Implemented by #21042 (Redmine 3.2.0). "Hide my email address" is checked by default for new users.

Also available in: Atom PDF