Defect #5049

Possible error 500 while moving an issue to another project with SQLite

Added by Michael Jahn over 7 years ago. Updated about 7 years ago.

Status:ClosedStart date:2010-03-11
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Issues
Target version:0.9.4
Resolution:Fixed Affected version:0.9.3

Description

Hi,

I get an "Internal Error 500" if I try to move an issue from one project to another one. I could break down the error to the
following cause: the issue has the tracker "Error" but this tracker is not available in the destination project.
Workaround:
Select an appropriate new tracker in the move dialog.
What I expected:
A better error message, that I have to select a new tracker value.

Especially strange is the error message in the server log:

SQLite3::SQLException (cannot rollback - no transaction is active):
  C:/Programme/Ruby/lib/ruby/gems/1.8/gems/sqlite3-ruby-1.2.5-x86-mswin32/lib/sqlite3/errors.rb:62:in `check'
  C:/Programme/Ruby/lib/ruby/gems/1.8/gems/sqlite3-ruby-1.2.5-x86-mswin32/lib/sqlite3/resultset.rb:56:in `check'
  C:/Programme/Ruby/lib/ruby/gems/1.8/gems/sqlite3-ruby-1.2.5-x86-mswin32/lib/sqlite3/resultset.rb:48:in `commence'
  C:/Programme/Ruby/lib/ruby/gems/1.8/gems/sqlite3-ruby-1.2.5-x86-mswin32/lib/sqlite3/resultset.rb:38:in `initialize'
  C:/Programme/Ruby/lib/ruby/gems/1.8/gems/sqlite3-ruby-1.2.5-x86-mswin32/lib/sqlite3/statement.rb:136:in `new'
  C:/Programme/Ruby/lib/ruby/gems/1.8/gems/sqlite3-ruby-1.2.5-x86-mswin32/lib/sqlite3/statement.rb:136:in `execute'
  C:/Programme/Ruby/lib/ruby/gems/1.8/gems/sqlite3-ruby-1.2.5-x86-mswin32/lib/sqlite3/database.rb:188:in `execute'
  C:/Programme/Ruby/lib/ruby/gems/1.8/gems/sqlite3-ruby-1.2.5-x86-mswin32/lib/sqlite3/database.rb:163:in `prepare'
  C:/Programme/Ruby/lib/ruby/gems/1.8/gems/sqlite3-ruby-1.2.5-x86-mswin32/lib/sqlite3/database.rb:187:in `execute'
  C:/Programme/Ruby/lib/ruby/gems/1.8/gems/sqlite3-ruby-1.2.5-x86-mswin32/lib/sqlite3/database.rb:597:in `rollback'
  app/models/issue.rb:95:in `move_to'
  app/controllers/issues_controller.rb:307:in `move'
  app/controllers/issues_controller.rb:299:in `each'
  app/controllers/issues_controller.rb:299:in `move'

The message doesn't point to the real cause of the error.

My installation:
Redmine 0.9.3 (Windows)
SQLite
Ruby 1.8.6 (i386-mswin32)
Rails 2.3.5
Database schema version 20100221100219

Associated revisions

Revision 3566
Added by Jean-Philippe Lang over 7 years ago

Fixed: error while moving an issue to a project with disabled tracker with SQLite3 (#5049).

History

#1 Updated by Michael Jahn over 7 years ago

I forgot to say: Great piece of software!
That's my first ticket, I have to say thanks. :)

#2 Updated by Jean-Philippe Lang over 7 years ago

  • Status changed from New to Resolved
  • Target version set to 0.9.4
  • Resolution set to Fixed

The error is fixed in r3566 (reproduced with slite3 only).
You should now get a message that says that the issue could not be saved. Now we just need to display the reason why...

#3 Updated by xt zhang over 7 years ago

Michael Jahn wrote:

I forgot to say: Great piece of software!

That's my first ticket, I have to say thanks. :)

me 2.
no ticket yet.

#4 Updated by Michael Jahn over 7 years ago

Many thanks for the quick fix!

#5 Updated by Jean-Philippe Lang over 7 years ago

  • Subject changed from Error 500 while moving an issue to another project to Possible error 500 while moving an issue to another project with SQLite
  • Status changed from Resolved to Closed

Also available in: Atom PDF