Feature #5196

Grouping, ordering and viewing issues list by parent tasks

Added by Vladimir Potekhin over 4 years ago. Updated over 1 year ago.

Status:ClosedStart date:2010-03-26
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Issues
Target version:-
Resolution:Fixed

Description

There is new feature subtasks in trunk (from r3573).
But there are not abilities to group or order issues by their parent tasks in project issues list.
Also there is not ability to include root/parent task column in issues list.
-
It will be very usefull to maintain project plan and control project progress.

tree_view.png (2.48 KB) Jean-Philippe Lang, 2010-03-27 18:00


Related issues

Related to Defect #5384: Subtickets not showing properly in issue list New 2010-04-26
Related to Defect #7646: Tasks organization Closed 2011-02-18
Duplicates Patch #5101: Show nested issues in a hierarchic list Closed 2010-03-17
Duplicated by Feature #5325: Grouping Issues by Parent ID Reopened 2010-04-15

Associated revisions

Revision 3618
Added by Jean-Philippe Lang over 4 years ago

Issue list improvements for subtasking (#5196):
  • makes the parent task column available
  • display the issue hierarchy when list is sorted by parent

History

#1 Updated by Jean-Philippe Lang over 4 years ago

  • File tree_view.png added
  • Status changed from New to Resolved
  • Resolution set to Fixed

r3618 makes the parent task column available on the issue list. If you sort issues by parent, you will get a tree view:

#2 Updated by Vladimir Potekhin over 4 years ago

Jean-Philippe, thank you!

I will try and test this feature and report results and applicability and facility of this realization.

#3 Updated by Felix Schäfer over 4 years ago

  • Status changed from Resolved to Closed

Emiliano Heyns wrote:

Since #5196 is already in, I would propose marking this a duplicate and closing it, I'll continue the discussion on #5196 itself.

Done.

#4 Updated by Felix Schäfer over 4 years ago

  • Status changed from Closed to Reopened

Wow, no idea how that last comment got here, but it should comment (and actually also does) #5101

@JPLang: 1. could you please reset the status to Resolved? 2. IIRC I added the duplicated by #5196 (this one here) relation in #5101, then closed and commented #5101, which seems to have duplicated the comment here. I'll try to reproduce it, but I'm not sure I'll have the time, could you try to give it a go?

#5 Updated by Jean-Philippe Lang about 4 years ago

  • Status changed from Reopened to Closed

Wow, no idea how that last comment got here, but it should comment (and actually also does) #5101

Closing an issue closes duplicates with the same comment.

#6 Updated by Toshi MARUYAMA over 1 year ago

  • Description updated (diff)

Also available in: Atom PDF