Defect #5373

Translation missing when adding invalid watchers

Added by Bogdan Matu over 7 years ago. Updated over 6 years ago.

Status:ClosedStart date:2010-04-22
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Translations
Target version:1.2.0
Resolution:Fixed Affected version:0.9.3

Description

When trying to create a new issues if you have more then one watcher assigned to the issue I get an error "translation missing: en, field_watcher_users is invalid"

Rails 2.3.5
Ruby 1.8.7


Related issues

Related to Redmine - Defect #8076: Watchers list issue Closed 2011-04-05
Duplicated by Redmine - Defect #6094: translation missing: en, field_watcher_users is invalid Closed 2010-08-09

Associated revisions

Revision 5880
Added by Jean-Philippe Lang over 6 years ago

Fixed: validation error on issue creation when trying to add an invalid user as a watcher (#5373).

History

#1 Updated by Felix Schäfer over 7 years ago

  • Category set to Translations

#2 Updated by Bogdan Matu over 7 years ago

This might be part of translations but it is a bug as well - It will not allow me to add more then one watcher. Yes the error message shows the code but the logic itself is not working

#3 Updated by Bogdan Matu over 7 years ago

It seems like it is just one user in the project. My appologies.

#4 Updated by Felix Schäfer over 7 years ago

Mmh, that's odd… Please provide the information listed in SubmittingBugs (especially the output of RAILS_ENV=production ruby script/about) and see if there is some meaningful error trace in the logs. We need to be able to reproduce this to help.

#5 Updated by Robert Chady over 7 years ago

I have run in to this behavior when the user set as a watcher was somehow invalid. The acts_as_watchable plugin does its own validity checking on the user above and beyond what Redmine does. Check over the user that is giving you the error and see if there is something not quite right about them.

#6 Updated by multi user over 7 years ago

  • Assignee set to Jean-Philippe Lang

Bonsoir,

Ce problème se produit si l'un des observateur partage la même adresse mail avec d'autres utilisateurs (ce qui était possible dans d'anciennes versions).
En modifiant les adresses mails, plus de problèmes.

Cdlt

#7 Updated by Jean-Baptiste Barth over 7 years ago

  • Subject changed from Multiple Watchers to Translation missing when adding invalid watchers
  • Assignee deleted (Jean-Philippe Lang)

#8 Updated by Brandon Bonds over 7 years ago

The above comment is correct... this happens when two users have the same email address for some reason. My issue #6094 is a duplicate and I'll copy that issue report here:

Issue 6094

I came across the following error whenever someone would create an issue with me as a watcher:

translation missing: en, field_watcher_users is invalid
It did not do the same for anyone else. And, I could be added as a watcher to an issue later.

I figured out the problem, and hopefully this will be a helpful hint if someone comes across this rare error. It turns out that my email address was in use by both my account and the "Administrator". So, I changed one of the email addresses and it started working correctly.

The current release does not allow this to even happen, but I assume I set this up in a prior release, or by manually editing the database. In either case, most people shouldn't come across the issue and I don't know if this is something worth looking into fixing.

#9 Updated by Christian Ziegelt over 6 years ago

Watchers seem to be invalid, if their personal settings are corrupted.

After migrating a 1.1.0 installation from one PC to a server with copying the database with a mysql dump, the settings for the users seemed to be corrupted.

One Error was the "missing translation" second error was "field_watcher_users is invalid" and third error was wne changing password "mail_notification" error.

After setting all the preferences via Control panel for the users, all of the errors disappeared.

#10 Updated by Luis Serrano Aranda over 6 years ago

I have the same problem, what do you mind with setting all preferences via Control Panel ?

(enter in my account change something and save ?

Thanks

#11 Updated by Etienne Massip over 6 years ago

Probably using Administration -> Settings -> Users and loading/saving preferences of each user.

#12 Updated by Jens Peter Kempkes over 6 years ago

We had the same issue, after we upgrade from 1.0.2 to 1.1.2 stable.

I went thru all users, opened their config page on the administration settings page and just saved the current config. after this the issue is gone.

Probably some database upgrade is missing, but no errors showed up during the upgrade.

Best,
jp

#13 Updated by Etienne Massip over 6 years ago

If someone could compare the contents of users table between "before" and "after" update states, that would be of a great help.

E.g., export data to csv and use a diff tool ?

#14 Updated by Zach Leslie over 6 years ago

In my case, I was unable to change any value of the user, because I was getting a message upon save that the login was already taken. Looking through the database, I found two users with the same name, different capitalization. Deleting one of the users has allowed me to save the record again and fix the issue. How was the second user allowed to be created?

I did dump the user table before and after, but doing a diff between them does not seem to show useful information, as the entire list of users in the database is all on one line.

Let me know if I can provide more information.

#15 Updated by Etienne Massip over 6 years ago

It could have been created by email if you use issue creation via email ?

#16 Updated by Fernan Hidabe over 6 years ago

I have solved it adding to my language file (es.yml), this text:
field_watcher_users: Seguidores

In my Language files (es.yml, en.yml, etc), redmine 1.1.2 version, dont exists line with: field_watcher_users :S

I tried open and save user, and it dont work.

Regards!

#17 Updated by nikolay parshin over 6 years ago

Jens Peter Kempkes wrote:

We had the same issue, after we upgrade from 1.0.2 to 1.1.2 stable.

I went thru all users, opened their config page on the administration settings page and just saved the current config. after this the issue is gone.

Probably some database upgrade is missing, but no errors showed up during the upgrade.

Best,
jp

I did the same and the error is gone

#18 Updated by Jean-Philippe Lang over 6 years ago

  • Status changed from New to Resolved
  • Target version set to 1.2.0
  • Resolution set to Fixed

Fixed in r5880, this error message should no longer occur.

#19 Updated by Terence Mill over 6 years ago

Why is that issue sill not closed?

#20 Updated by Jean-Philippe Lang over 6 years ago

  • Status changed from Resolved to Closed

Terence Mill wrote:

Why is that issue sill not closed?

Because fix was not merged into 1.2-stable branch. Done in r5945.

Also available in: Atom PDF