Defect #5381

Issues of a deleted project are not deleted

Added by gabriel scolan over 7 years ago. Updated over 4 years ago.

Status:ClosedStart date:2010-04-26
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:-
Target version:-
Resolution: Affected version:0.9.3

Description

In version 0.9.3, it seems that when a project is deleting, the associated issues are not deleted.
One side effect of this is that there is no more possibility to delete a tracker that was only used in the deleted project, since the issues continue existing.

Associated revisions

Revision 3693
Added by Jean-Philippe Lang over 7 years ago

Adds an assertion on issues deletion when deleting a project (#5381).

History

#1 Updated by Jean-Philippe Lang over 7 years ago

A test was added in r3693 in trunk. It also passes on 0.9-stable.
Please, provide some details on how to reproduce.

#2 Updated by gabriel scolan over 7 years ago

here is the scenario:
  • delete all the projects in which the tracker you want to delete is used.
  • try and delete the tracker from the admin interface ==> not possible
  • check the sql db : all the issues of the deleted projects still exists.

one possible root cause could be that I deleted projects containing sub-projects.

#3 Updated by Jean-Baptiste Barth over 7 years ago

Are you sure projects are deleted, not just archived ?

I cannot reproduce the problem on current trunk :
  • created a tracker "EvilTracker", affected it to a project
  • created an issue on this project+tracker
  • deleted the project
  • deleted the tracker => ok
  • verified the issue is deleted => ok

I leave the issue opened as I suspect there is a defect here, but please provide minimal steps to reproduce on a frech clean install. And provide as many details as possible.

#4 Updated by Ivan Cenov over 4 years ago

I tested now in trunk r11640:
  1. Created a project
  2. Created an issue in it
  3. Deleted project
  4. Refreshed the page with the issue - 404 returned -- the issue has been deleted.

May be this issue could be closed?

#5 Updated by Daniel Felix over 4 years ago

  • Status changed from New to Needs feedback

Did you check the database too if they are deleted too? This is one thing which is named by the author.

#6 Updated by Daniel Felix over 4 years ago

  • Status changed from Needs feedback to Closed

Ivan commented here: http://www.redmine.org/boards/1/topics/35571?r=36950#message-36950

The database entries were deleted too. This is one seems to be fixed and could be closed.

Also available in: Atom PDF