Feature #5462

Blocking issues to be closed which have open subtasks

Added by Yuki Kita over 7 years ago. Updated about 1 year ago.

Status:ClosedStart date:2010-05-07
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Issues
Target version:-
Resolution:Duplicate

Description

Now We can close issues that have have open subtasks.
This behavior enables confusing situation that a parent task is closed, though subtasks are open.
It would be nice that Redmine blocks a issue to be closed if the issue have any open subtasks.


Related issues

Duplicates Redmine - Feature #10989: Prevent parent issue from being closed if a child issue i... Closed

History

#1 Updated by Nigel Jones over 7 years ago

Blocking the action may be too much - but a popup warning would be nice. This would let the user know that there are outstanding subtasks but not stop them closing the issue if that's what they want to do.

#2 Updated by Yuki Kita over 7 years ago

Nigel Jones wrote:

Blocking the action may be too much - but a popup warning would be nice. This would let the user know that there are outstanding subtasks but not stop them closing the issue if that's what they want to do.

I agree.
The popup warning is better.

#4 Updated by Sheng Wang over 7 years ago

I think Redmine should block parent task to be closed when there are open subtasks.

#5 Updated by Laszlo Horvath about 5 years ago

+1

#6 Updated by Ariel Lira about 3 years ago

I think this is fixed in 2.4.x+

#7 Updated by Toshi MARUYAMA almost 3 years ago

Ariel Lira wrote:

I think this is fixed in 2.4.x+

Redmine core does not support this feature yet.

#8 Updated by Florian ROBERT about 2 years ago

+1

#9 Updated by Maicon Zucco almost 2 years ago

+1

#10 Updated by David Songer about 1 year ago

As a relative new user of RedMine (and I'm enjoying setting up new projects), I'm trying to work out if this issue has been fixed in V3.3? The new project I'm developing will benefit from not being able to close a parent issue with open sub-tasks. Can anyone confirm that this is the case with V3.3, that parent issues with open sub-tasks cannot be closed? Thanks

#11 Updated by Toshi MARUYAMA about 1 year ago

  • Status changed from New to Closed
  • Resolution set to Duplicate

Duplicate of #10989.

#12 Updated by Toshi MARUYAMA about 1 year ago

  • Related to deleted (Feature #13585: Make sub-task inherit the properties of parent)

#13 Updated by Toshi MARUYAMA about 1 year ago

  • Duplicates Feature #10989: Prevent parent issue from being closed if a child issue is open added

Also available in: Atom PDF