Defect #5538

Default 'my page' widgets lost after adding first widget.

Added by Dominic Clifton over 8 years ago. Updated 10 months ago.

Status:ClosedStart date:2010-05-17
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:My page
Target version:-
Resolution:Wont fix Affected version:2.2.1

Description

Steps to repeat:

  1. login with a new user account
  2. click 'my page'
  3. click 'personalize'
  4. choose a widget, click 'add'
  5. observe new widget it added to the page, along side existing widgets.
  6. click 'my page' to reload the page.
  7. observe that only the just-added widget is displayed and the previous default widgets are no longer present.

Expected behviour

  • Default widgets are displayed on subsequent page views along side newly added widget.

Notes

This occurs on www.redmine.org as of 17/May/2010 and on my local instance.

keep_default_widgets.diff Magnifier (3.1 KB) Holger Just, 2010-05-17 15:44

History

#1 Updated by Holger Just over 8 years ago

I can confirm the issue on a local trunk installation. It does only occur for new users which have not yet an entry in the user_preferences table. Following r3194, the my page layout is initialized empty instead with DEFAULT_LAYOUT. The attached patch fixes this and provides some tests.

#2 Updated by Daniel Felix almost 6 years ago

  • Category set to My page
  • Status changed from New to Confirmed
  • Affected version (unused) set to 2.2.1
  • Affected version set to 2.2.1

I can confirm this misbehaviour.

This is still included in Redmine 2.2.1.

The patch looks good in my opinion. It should correct this bug.

#3 Updated by Etienne Massip almost 6 years ago

  • Target version set to Candidate for next minor release

There's even a test, woohoo.

#4 Updated by Marius BALTEANU 10 months ago

  • Status changed from Confirmed to Closed
  • Resolution set to Wont fix

I'm closing this issue because "My page" was refactorized in 3.4.0 and "Personalize" mode doesn't exists anymore (the widgets are edited inline). Please reopen it if I'm wrong.

#5 Updated by Marius BALTEANU 10 months ago

  • Target version deleted (Candidate for next minor release)

Also available in: Atom PDF