Feature #5664

Copying documents too when copying a project

Added by Pedro Gutierrez over 7 years ago. Updated 6 months ago.

Status:ClosedStart date:2010-06-10
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Documents
Target version:-
Resolution:Duplicate

Description

Currently, when you copy a project there is no possibility to copy the documents it contains (either all or a selection of them).

Concretely we are interested in creating a project template that includes not only wiki pages and issues but also certain basic documents such as for example:
  • An Openproj template we use for planning before the projects formally start
  • An excel sheet we use for projects that need additional monitoring
  • Document templates for lifecycle specific internal deliverables

feature_5664_copy_docs.diff Magnifier (2.31 KB) Michael Esemplare, 2014-01-06 09:02

feature_5664_copy_docs_w_tests_trunk.diff Magnifier (4.78 KB) Michael Esemplare, 2014-01-11 09:21

0001-Adds-ability-to-copy-documents-when-copying-a-projec.patch Magnifier (5.38 KB) Michael Esemplare, 2014-08-15 04:34


Related issues

Related to Redmine - Feature #5457: Move files and documets to another project New 2010-05-06
Duplicates Redmine - Patch #26621: Allow to copy documents along with projects New

History

#1 Updated by Pedro Gutierrez over 7 years ago

This is related to #5457

#2 Updated by Ian Epperson about 7 years ago

Also related to #886 and #3367. I'd like to see this added for the same reasons given here.

#3 Updated by Toshi MARUYAMA over 4 years ago

  • Category set to Documents

#4 Updated by Michael Esemplare about 4 years ago

Added patch against 2.4-stable for copying documents when copying a project.

#5 Updated by Michael Esemplare about 4 years ago

Added patch against trunk and updated unit tests.

#6 Updated by Michael Esemplare over 3 years ago

Uploaded a patch to provide this feature.

The patch will be kept up to date in this feature branch:
https://github.com/esemplare/redmine/tree/feature_5664

This patch is against redmine/trunk.

#7 Updated by Hugues C. over 1 year ago

Isn't this a bug ? The expected behavior for the average user : copying a project means copying everything, not everything except documents.

#8 Updated by Kamil . 10 months ago

Bug which is already 7 years old?!

#9 Updated by Go MAEDA 6 months ago

  • Status changed from New to Closed
  • Resolution set to Duplicate

Closing this issue because an updated patch for the current trunk has been submitted as #26621.

#10 Updated by Go MAEDA 6 months ago

  • Duplicates Patch #26621: Allow to copy documents along with projects added

Also available in: Atom PDF