Feature #5684

new custom field type - "redmine users"

Added by Maxim Nikolaevich over 7 years ago. Updated almost 7 years ago.

Status:ClosedStart date:2010-06-14
Priority:LowDue date:
Assignee:-% Done:

0%

Category:Custom fields
Target version:-
Resolution:Duplicate

Description

I need additional field: inspector
role in project who check resolving of task.
so at current moment i can get same functional via creating new task in separate tracker "called" inspection with name "check resolving of task #xxx" but this way is not so elegant...


Related issues

Duplicates Redmine - Feature #2096: Custom fields referencing system tables (users and versio... Closed 2008-10-27

History

#1 Updated by Felix Schäfer over 7 years ago

I'm not sure I understand what your problem is, but if you want to have a workflow where your developers correct a bug or implement a feature, but that it needs to be verified by an inspector first before it's committed, that's a job for the workflow. You can change the workflow so that developers can only put an issue up to the state "to be verified" from which only an inspector can take it to "closed".

#2 Updated by Maxim Nikolaevich over 7 years ago

Yes, i do this way but... who are inspector?
I asked for "inspector" field to allow users with inspector role have acces to task which he should inspect via filter.
Yes it's possible to solve this via changing assign role. But this way also not so elegant cause information about how many tasks resolved will be missed in this way.
I hope now it's clear.

#3 Updated by Felix Schäfer over 7 years ago

So you're asking for the wrong thing. What need isn't a custom field, I think that would be the wrong approach, what you want is way to filter issues with regard to a certain transition, so something like "show me all issues set to status "to be verified" by Maxim", right?

#4 Updated by Maxim Nikolaevich over 7 years ago

Yes, you are right. Are there other way to do this except custom field?

#5 Updated by Nils Linde about 7 years ago

I totally agree. There should be a custom field type "User" and "Group", so it could be used to add fields to issues.
Usage examples:
"Feature user" if problem is for antoher user, but new issue is added by another user
"Group manager" if groups are used to define departments in company (not speaking about possibility to set a parent/child group id/name, to make group hierarchy), it is good, to be able to define different roles for groups
"Assigned group" to assign a specific group to issue, for example, Technical department. If group is added to issue, the group manager is noticed (if "Group manager" function is avilable)

I can think tons of more usages for this stuff and that should not be hard to implement, as there already is field "Assigned user", that is for issues.

#6 Updated by Maxim Nikolaevich about 7 years ago

  • Status changed from New to Resolved

This issue dup #2096

#7 Updated by Etienne Massip almost 7 years ago

  • Status changed from Resolved to Closed
  • Resolution set to Duplicate

Closed as duplicate of #2096.

Also available in: Atom PDF