Defect #5688

Version editing not accepting valid Date input

Added by William Wedin over 9 years ago. Updated about 4 years ago.

Status:ClosedStart date:2010-06-15
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Roadmap
Target version:-
Resolution: Affected version:

Description

When submitting a new Version or editing an existing one, if I attempt to submit a date, I get the error "Date is not a valid date," and the data is not committed to the database. Checking the log file, I can see that the date is exactly correct, in yyyy-mm-dd format with no whitespace.

Commenting out the "validates_format_of :effective_date" line in version.rb fixes the problem, but this is obviously a less-than-ideal solution. The issue has been occurring for several versions now, on two different (but similarly configured) servers.

About your application's environment
Ruby version 1.8.6 (i386-mswin32)
RubyGems version 1.3.5
Rack version 1.0
Rails version 2.3.5
Active Record version 2.3.5
Active Resource version 2.3.5
Action Mailer version 2.3.5
Active Support version 2.3.5
Application root C:/redmine
Environment development
Database adapter sqlserver
Database schema version 20100313171051

Redmine r3768
MS SQL Server 2008

History

#1 Updated by Felix Schäfer over 9 years ago

Please submit the error trace from the logs.

#2 Updated by William Wedin over 9 years ago

There is no trace. It's a validation failure only.

Here's the entry from the log, though:

Processing VersionsController#new (for 64.115.158.91 at 2010-06-14 15:28:50) [POST]
Parameters: {"project_id"=>"versentiaonline", "commit"=>"Create", "action"=>"new",
    "authenticity_token"=>"e8Ijc0I/bUeqeQvkHLESfZy0Vrcw3Hi8NoFqOe6M+t0=", "controller"=>"versions",
    "version"=>{"status"=>"open", "name"=>"CitySpec Release", "wiki_page_title"=>"", "description"=>"", "sharing"=>"none",
    "effective_date"=>"2010-06-30"}}
Rendering template within layouts/base
Rendering versions/new
Completed in 609ms (View: 485, DB: 45) | 200 OK [https://issues.turntype.com/projects/versentiaonline/versions/new]

#3 Updated by Daniel Felix almost 7 years ago

  • Category set to Roadmap
  • Status changed from New to Needs feedback

I'm not able to reproduce this with Redmine 2.2.1.

Anyone else who can confirm that this bug is fixed?

#4 Updated by Go MAEDA about 4 years ago

  • Status changed from Needs feedback to Closed

No feedback for years.
Closing.

Also available in: Atom PDF