Defect #5724

Email creation of new issues for anonymous users failing due to email address length

Added by Ade Fewings over 7 years ago. Updated about 6 years ago.

Status:ClosedStart date:2010-06-22
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Email receiving
Target version:-
Resolution:Duplicate Affected version:

Description

Having upgraded from an older version (which was without the ability to accept issues via email from unknown email addresses) to the current SVN trunk in order to gain such anonymous posting functionality, have seen some issues regarding issues not being accepted from the submission script and returning error 422. I have traced this back at established that it is caused by the 'From' email address being of more than 32 characters, which I believe collides with the length of the username field when RedMine attempts to create the anonymous user for the issue.

Maybe not an issue to be 'fixed' but maybe it is?

Thanks, loving RedMine


Related issues

Duplicates Redmine - Defect #7717: MailHandler user creation for unknown_user impossible due... Closed 2011-02-25

History

#1 Updated by Felix Schäfer over 7 years ago

  • Category set to Email receiving
  • Affected version (unused) set to devel

This indeed is a problem if confirmed.

#2 Updated by Jean-Philippe Lang about 6 years ago

  • Status changed from New to Closed
  • Resolution set to Duplicate

Same as #7717, fixed in r7952.

Also available in: Atom PDF