Defect #5769

Popup Calendar doesn't Advance in Chrome

Added by Rafael Diaz-Tushman over 7 years ago. Updated over 7 years ago.

Status:ClosedStart date:2010-06-28
Priority:NormalDue date:
Assignee:Eric Davis% Done:

100%

Category:Issues
Target version:1.0.0 (RC)
Resolution:Fixed Affected version:0.9.4

Description

Redmine 0.9.4.devel.3764 (MySQL)

When using the popup calendar in Chrome, you cannot advance more than one click (month/year). If you advance twice, the popup calendar goes blank. I can recreate this bug even here (see attached screenshot)

This doesn't happen in Firefox.

blank_popup_calendar.png (82.3 KB) Rafael Diaz-Tushman, 2010-06-28 17:14

001_fixed_integer_subtraction.diff Magnifier (462 Bytes) Holger Just, 2010-06-28 19:20

Associated revisions

Revision 3822
Added by Eric Davis over 7 years ago

Fix Chrome JavaScript bug in the pop up calendar. #5769

Contributed by Holger Just

History

#1 Updated by Holger Just over 7 years ago

I can confirm the issue on Chrome 5.0.375.86 on OSX 10.6. The error message is "Uncaught illegal access in /javascripts/calendar/calendar.js?1277038037:1108"

The issue is the same as http://code.google.com/p/chromium/issues/detail?id=43973. The proposed fix in this ticket solves the issue for me. I transformed it into a patch to Redmine and attached it here.

#2 Updated by Rafael Diaz-Tushman over 7 years ago

Perfect, that fixed it.

#3 Updated by Holger Just over 7 years ago

Eric, could you please commit this patch?

#4 Updated by Eric Davis over 7 years ago

  • Status changed from New to Closed
  • Assignee set to Eric Davis
  • Target version set to 1.0.0 (RC)
  • % Done changed from 0 to 100
  • Resolution set to Fixed

I didn't have any issues with Chrome 5.0.342.9 beta on Linux but this does look like a JavaScript coding bug. Applied in r3822.

Also available in: Atom PDF