Defect #5906

Changeset scanner doesn't check if status is within trackers workflow

Added by Alex Cartwright over 7 years ago. Updated over 7 years ago.

Status:ClosedStart date:2010-07-19
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:-
Target version:-
Resolution:Duplicate Affected version:

Description

The current changeset scanner/parser doesn't check if the status it is about to be set to is within the trackers workflow.

For example, I have a 'Feature' tracker with issue #1337 and a 'fixing keyword' setup of 'Fixed'. If within a commit message I enter in 'Fixed #1337' the status of this issue will be set to 'Fixed'. However, 'Fixed' isn't within the 'Feature' tracker workflow since we don't fix features, we implement them.

This has lead to issues when it comes to altering the status of this issue, since I can't change it to anything as 'Fixed' is not within the workflow.


Related issues

Duplicates Redmine - Defect #1513: Fixing issues in commit messages can break the workflow Reopened 2008-06-21

History

#1 Updated by Mischa The Evil over 7 years ago

  • Status changed from New to Closed
  • Affected version (unused) set to devel
  • Resolution set to Duplicate

Closed as a duplicate of issue #1513.

Alex: thanks for bringing this up again...

Also available in: Atom PDF