Feature #6027

Global wiki and forum

Added by Jonas Nyrén over 7 years ago. Updated over 7 years ago.

Status:ClosedStart date:2010-08-03
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:-
Target version:-
Resolution:Duplicate

Description

I would like to suggest the possibility to have a global wiki and forum instead of separate ones per project. We have multiple projects and it would be nice if we could house all forums in one place. The same goes for the wiki where much of the information is similar or even the same between projects (how to build, code formatting standards, and so on).


Related issues

Duplicates Redmine - Feature #1040: Global wiki Reopened 2008-04-10
Duplicates Redmine - Feature #3048: Central Wiki, FAQ, Documents, etc. for different Projects New 2009-03-25

History

#1 Updated by Terence Mill over 7 years ago

You can create a top level project only with module wiki and forum and then some subprojects without these modules.

#2 Updated by Enderson Maia over 7 years ago

I use the same solution that Terence Mill suggested.

I have a group called "All Users" that is member of the "Global Project" with a Role that has little privileges, and only to Wiki (I don't use Forums).

I don't use public groups, and every new user i make member of the group "All Users".

#3 Updated by Enderson Maia over 7 years ago

Enderson Maia wrote:

...
I don't use public groups, and every new user i make member of the group "All Users".

I mean public projects.

#4 Updated by Jonas Nyrén over 7 years ago

Thank you for that suggestion. I had not thought of this workaround. I still wish it would be a bit more obvious, but I can live with this solution.

#5 Updated by Ebrahim Mohammadi over 7 years ago

I still think suggested workarounds are not solutions, but just workarounds. A global wiki and forum would be useful.
For example software companies that consist of a few development teams, each having their own top-level project, could share the common knowledge in a global wiki and forum. Note that in such a situation a parent-of-all project is not natural.

#6 Updated by Felix Schäfer over 7 years ago

  • Status changed from New to Closed
  • Resolution set to Duplicate

Closing as being parts duplicate of #1040 and #3048. Added an FAQ entry to cover that request.

Also available in: Atom PDF