Defect #6267

changing the authentication mode from ldap to internal with setting the password

Added by Sebastian Rick about 7 years ago. Updated about 7 years ago.

Status:ClosedStart date:2010-09-01
Priority:NormalDue date:
Assignee:Eric Davis% Done:

100%

Category:LDAP
Target version:1.0.2
Resolution:Fixed Affected version:1.0.1

Description

Database: PostgreSQL 8.4
Ruby: 1.8.7
Rails: 2.3.5

error description:
On changing the authentication mode from ldap to internal and set the new password in one step, this will result in an changed authentication mode with an unchanged password. The notification via mail shows the changed password, but it wouldn't be changed. The redmine-log shows no error. Also all other logs, e.g. postgres, shows quiet good.

Associated revisions

Revision 4066
Added by Eric Davis about 7 years ago

Allow user password changes when changing to Internal authentication. #6267

History

#1 Updated by Eric Davis about 7 years ago

  • Category set to LDAP
  • Assignee set to Eric Davis
  • Target version set to 1.0.2

I'm guessing that the password is getting set before the authentication mode is changed. Since LDAP doesn't allow password changes, the change is "lost". I'll try to reproduce it and see about fixing it in 1.0.2.

#2 Updated by Eric Davis about 7 years ago

  • Status changed from New to Resolved
  • % Done changed from 0 to 100
  • Resolution set to Fixed

Fixed in r4066.

#3 Updated by Eric Davis about 7 years ago

  • Status changed from Resolved to Closed

Merged into 1.0-stable for release in 1.0.2

Also available in: Atom PDF