Feature #6347

All members not being displayed in Projects -> Settings

Added by Dave Martin about 7 years ago. Updated about 4 years ago.

Status:ClosedStart date:2010-09-10
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Projects
Target version:-
Resolution:Duplicate

Description

There is a hard limit of 100 in the Principal.active.find call in 'app/views/projects/settings/_members.rhtml':

<% principals = Principal.active.find(:all, :limit => 100, :order => 'type, login, lastname ASC') - @project.principals %>

which is a problem for us as we currently have 135 members. Please consider raising or removing this limit.


Related issues

Duplicates Redmine - Defect #9549: Only 100 users are displayed when adding new project members Closed 2011-11-11

History

#1 Updated by Jean-Baptiste Barth about 7 years ago

  • Resolution set to Wont fix

Thanks for reporting. I don't think we will increase this limit because there are good reasons behind it.

But did you notice you have an autocomplete text field above it ? When you start typing anything in it, names are auto-completed accordingly... Do you see a better / more intuitive method to do that ?

#2 Updated by Daniel Felix almost 5 years ago

  • Resolution deleted (Wont fix)

Well I know that there is no pagination on this page and the limit won't be raised. But...
I would definitly agree that ther should be some kind of pagination. This way, the limit could be removed and the display would be still fast.

What do you think Jean-Baptiste?

#3 Updated by Daniel Felix almost 5 years ago

  • Tracker changed from Defect to Feature

It should be a feature request, if there should be some pagination.

#4 Updated by Jean-Philippe Lang almost 5 years ago

  • Target version set to Candidate for next major release

#5 Updated by Bruce Svare about 4 years ago

This is a duplicate of #9549 which was implemented in 2.3.0

#6 Updated by Daniel Felix about 4 years ago

  • Duplicates Defect #9549: Only 100 users are displayed when adding new project members added

#7 Updated by Daniel Felix about 4 years ago

  • Status changed from New to Closed
  • Target version deleted (Candidate for next major release)
  • Resolution set to Duplicate

Indeed. I close this issue, as this issue is already fixed.

I set the relation as a duplicate, even if this issue is the one which was first - the other issue find it's way to the trunk.

Also available in: Atom PDF