Defect #6422

timetracking: subtasks time is not added to the main task

Added by Sergei Danilov about 7 years ago. Updated 5 months ago.

Status:ClosedStart date:2010-09-17
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Roadmap
Target version:-
Resolution: Affected version:1.0.1

Description

I logged to demo.redmine.org and created 3 tasks in my "Dany Project" project:

1) feature1 - no estimate - target version 1

subtasks for feature1:
2) subtask1 - estimate 1 hours - NO target version (compare with #5265)
3) subtask2 - estimate 1 hours - NO target version (compare with #5265)

I see total estimated time for feature1 is 2 hours.
But in the roadmap estimated time is 0 hours.


Related issues

Related to Redmine - Defect #5265: timetracking: subtasks time is added to the main task Closed 2010-04-07
Related to Redmine - Feature #9991: Estate parent task vs subtask Closed
Duplicated by Redmine - Defect #7515: Roadmap Version Time Tracking Error Closed 2011-02-01

History

#1 Updated by Mischa The Evil about 7 years ago

  • Category changed from Time tracking to Roadmap

#2 Updated by Etienne Massip over 6 years ago

  • Target version set to Candidate for next minor release

#3 Updated by Anton Nepomnyaschih over 6 years ago

+1 :)

It would be cool, if estimated time for version calculated as sum of all tickets that are assigned to the version. But without duplicated time (if some subtasks where summed to a parent task). In such case it worked in all 3 ways:
if version would be assigned to all parent tasks and their subtasks
if version would be assigned to only parent tasks, without their subtasks
if version would be assigned to only subtasks, without their parent tasks ;)

#4 Updated by Maarten Klerk over 5 years ago

+ 1 really need to have the total estimates of a version summed correctly. We want to learn what the compliancy of the teams estimates vs. spent time, so we can measure team velocity of Scrum team.

#5 Updated by Radek Karban over 5 years ago

+1

#6 Updated by Luis Serrano Aranda over 3 years ago

+1

#7 Updated by Florian Gruber almost 3 years ago

+1

#9 Updated by Diogo Soares 10 months ago

How to fix? Same error in version 3.2.1.stable

#10 Updated by Kishan Patel 6 months ago

+1

#11 Updated by Holger Just 6 months ago

The roadmap only shows estimates and spent time for issues which are assigned to a certain version. Just because a parent issue is assigned to a version does not mean that all its child issues are also implicitly assigned to the same version.

In the issues details page, you nowadays have two value for both estimated and spent time:

  • The time set on the individual issue only
  • The time of the issue plus all its sub-issues (the total time)

Now the roadmap only considers the individual time of all the issues explicitly assigned to the version. If you want your sub-issues to also be part of the version, just add them there. Then everything should work as designed (and fixed in #5265).

#12 Updated by Toshi MARUYAMA 5 months ago

  • Status changed from New to Closed
  • Target version deleted (Candidate for next minor release)

Also available in: Atom PDF