Defect #6506

Gantt chart export to PDF/PNG works incorrectly in zh-tw locale

Added by ChunChang Lo about 7 years ago. Updated over 6 years ago.

Status:ClosedStart date:2010-09-27
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Gantt
Target version:-
Resolution:Duplicate Affected version:

Description

PDF
  • project without open issue -> the lower half of the table is missing in the resulting PDF
  • project with lots of open issue -> too many pages in the resulting PDF
PNG
  • Chinese characters are not rendered correctly

By the way, the zh-tw day names used in Gantt chart should use short names rather than long names too as reported in issue #6502.

google-app-engine-gantt.pdf - PDF export of the project without open issue (5.5 KB) ChunChang Lo, 2010-09-27 08:11

google-app-engine-gantt.png - PNG export of the project without open issue (5.28 KB) ChunChang Lo, 2010-09-27 08:11

ipd-rework-gantt.pdf - PDF export of the project with lots of open issue (139 KB) ChunChang Lo, 2010-09-27 08:11

ipd-rework-gantt.png - PNG export of the project with lots of open issue (357 KB) ChunChang Lo, 2010-09-27 08:11


Related issues

Related to Redmine - Defect #6502: Gantt chart day_name error Closed 2010-09-27
Duplicates Redmine - Defect #61: Broken character encoding in pdf export Closed
Duplicates Redmine - Defect #4787: Gannt to PNG - CJK (Chinese, Japanese and Korean) charac... Closed 2010-02-10

History

#1 Updated by Mischa The Evil about 7 years ago

  • Category set to Gantt

#2 Updated by Toshi MARUYAMA over 6 years ago

  • Status changed from New to Closed
  • Resolution set to Duplicate

PDF is duplicate of #61.
PNG is duplicate of #4787.

Also available in: Atom PDF