Feature #6530

Allow multiple projects with same name

Added by Ian DeFazio about 7 years ago. Updated about 7 years ago.

Status:ClosedStart date:2010-09-29
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:-
Target version:-
Resolution:Duplicate

Description

Not sure if this should be a feature or patch?

I setup redmine to be used as a service database for customer issue tracking. I would like to be able to use a project name for multiple instances. This would allow me to setup a customer, then have a subproject for each piece of equipment they have. I could then use the serial number of that product as the unique identifier.

Ex:
Customer1
- product1
- product2
Customer2
- product1
- product2

Currently i can only use a project name once, so i have to do something like this

Customer1
- product1_c1
- product2_c1
Customer2
- product1_c2
- product2_c2

It's just a bit of a pain, and does not look as clean as i would like while listing the projects.

If anyone has any suggestions on an alternate way to do this that would be great!

Thanks for any help.
Ian


Related issues

Duplicates Redmine - Feature #630: Allow non-unique names for projects Closed 2008-02-11

History

#1 Updated by Felix Schäfer about 7 years ago

  • Status changed from New to Closed
  • Resolution set to Duplicate

Closing as duplicate of #630. The short version: one could create wiki links to a specific page in a project with the project name instead of identifier, which requires unique names, but we will probably remove this option from the wiki links and make project names non-unique.

Also available in: Atom PDF