Defect #6859

Moving issues to a tracker with different custom fields should let fill these fields

Added by Gabriel Baez about 7 years ago. Updated almost 6 years ago.

Status:ClosedStart date:2010-11-09
Priority:NormalDue date:
Assignee:Jean-Philippe Lang% Done:

0%

Category:Issues
Target version:1.4.0
Resolution:Fixed Affected version:

Description

We have upgraded our redmine from 0.8.3 to redmine to Redmine 1.0.2.stable everything seems to work with the exception of moving tickets to a different tracket, we get the following error message "Failed to save 1 issue(s) on 1 selected: #1393" I upgraded our test server to 1.0.3 and still have the same issue.


Related issues

Duplicated by Redmine - Defect #9277: copy issue from one project to another with different tra... Closed 2011-09-19
Duplicated by Redmine - Defect #9797: Move issue between projects fails if more than one proper... Closed

History

#1 Updated by Andrew Vit about 7 years ago

Confirmed. The problem seems to happen for issues with parent tasks.

I have the following in the history for one issue:

Updated by Andrew about 22 hours ago
  • Tracker changed from Bug to Feature
Updated by Andrew about 22 hours ago
  • Parent task set to #5
Updated by Andrew Vit about 22 hours ago
  • Tracker changed from Support to Feature
Updated by Andrew Vit about 22 hours ago
  • Tracker changed from Support to Feature

After the first change, the issue becomes a "Feature" as expected. After the second change, it goes into "Support" without being asked, and will not change from there unless the parent task is removed.

#2 Updated by Gabriel Baez about 7 years ago

Thanks for taking the time to look into this, but the issues that I have been trying to move do not have a parent task assigned.

#3 Updated by Andrew Vit about 7 years ago

I had a look through the source but I'm not familiar enough with Redmine to see what's happening.

Not sure if my issue is related or if I just hijacked your issue... Mine could be a different problem since yours gives an error and also happens without parent tasks.

#4 Updated by Gabriel Baez almost 7 years ago

anyone have any ideas for fixing this issue ?

#5 Updated by Gabriel Baez almost 7 years ago

environment info

[svn@dsvnrepo redmine]$ ruby -v
ruby 1.8.7 (2010-01-10 patchlevel 249) [i686-linux]
[svn@dsvnrepo redmine]$ rails -v
Rails 2.3.9

Database
mysql  Ver 14.14 Distrib 5.1.50, for pc-linux-gnu (i686) using readline 5.1

#6 Updated by Gabriel Baez almost 7 years ago

I have looked more into this issue and found a work around. the update was failing because the other tracker has required custom fields. once the "required" option was turned off we are now able to move tickets to another tracker.

#7 Updated by Etienne Massip over 6 years ago

  • Category set to Issues

Any plugins ?

#8 Updated by Etienne Massip over 6 years ago

Sorry, too fast, didn't see note 6.

Would be nice to have a more detailed error message.

#9 Updated by Gabriel Baez over 6 years ago

  • Status changed from New to Resolved

Hi, this is no longer an issue. The problem was that the tracker that I was trying to move to had required fields. It took sometime to figure out since redmine does not give any warnings about required fields for the tracker trying to move to. so it fails the save operation.

#10 Updated by Jean-Baptiste Barth over 6 years ago

  • Subject changed from Unable to move tickets to a different tracker. to Move issues to a different tracker with required fields should output explicit errors or help messages
  • Status changed from Resolved to New
  • Priority changed from Urgent to Normal

We should improve the error message if we don't provide a way to fill these fields.

#11 Updated by Etienne Massip almost 6 years ago

  • Target version set to Candidate for next major release

#12 Updated by Sebastian M almost 6 years ago

While I agree a better error message would be good, I would like to see the issue corrected functionally.

My preference would be that when moving an issue, any custom fields in the destination project, particularly required ones, are shown on the move page. This gives the mover the opportunity to set the proper values and the move could succeed.

Thanks

#13 Updated by Jean-Philippe Lang almost 6 years ago

  • Subject changed from Move issues to a different tracker with required fields should output explicit errors or help messages to Moving issues to a tracker with different custom fields should let fill these fields
  • Status changed from New to Closed
  • Assignee set to Jean-Philippe Lang
  • Target version changed from Candidate for next major release to 1.4.0
  • Resolution set to Fixed

Already fixed for 1.4.0. When moving issue(s) to a different project or tracker, you are now able to fill the target custom fields. BTW, the "Move" functionnality has been cleaned up and merged into the regular edit/bulk_edit form.

Also available in: Atom PDF