Feature #6972

Custom fields in timelog report

Added by Maciej Czub almost 7 years ago. Updated almost 7 years ago.

Status:ClosedStart date:2010-11-24
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Time tracking
Target version:-
Resolution:Duplicate

Description

In this article: http://www.redmine.org/wiki/redmine/RedmineCustomFields
we can find following description of Redmine functionality:

Data in spent time entry custom fields can be used and/or will be displayed in the Timelog report.

I can't find this function in Redmine. Am I missing something or this function is not implemented?


Related issues

Related to Redmine - Feature #1766: Custom fields should become addable to Spent Time list/re... Closed 2008-08-11
Duplicates Redmine - Feature #1692: Enable time-tracking additional fields in reports filters New 2008-07-28

History

#1 Updated by Felix Schäfer almost 7 years ago

I think this has been added in trunk but hasn't made its way to stable yet, sorry.

#2 Updated by Maciej Czub almost 7 years ago

I'm using trunk branch (1.0.3.devel.4425 at the moment) and I don't see it.

#3 Updated by Mischa The Evil almost 7 years ago

  • Status changed from New to Closed
  • Resolution set to Duplicate

Felix Schäfer wrote:

I think this has been added in trunk but hasn't made its way to stable yet, sorry.

Nope, this feature has been available since Redmine 0.8. It was added in r1689, r1690 and r1691 for issue #772. Though, it has not been integrated completely; see below...

Maciej Czub wrote:

I'm using trunk branch (1.0.3.devel.4425 at the moment) and I don't see it.

It is slightly more complicated; let me explain:
 


Because Redmine has two time-entry reports, each having multiple output-formats (HTML, CSV and ATOM), we have to describe them separately and more explicit.

RedmineTimelogDetails (AKA Spent-time details)

HTML

No STCF data is displayed.

CSV

All STCF data is exported.

ATOM

No STCF data is exported.

RedmineTimelogReport (AKA Spent-time report)

HTML

Some STCF data is displayed. Only data on STCF's of the type boolean and list can be used to filter the report.

CSV

Some STCF data is exported. Only data on STCF's of the type boolean and list is exported and this data is only added to the resulting CSV-file when the report is filtered using a filter containing data on STCF's of the type boolean and list.

ATOM

ATOM output is currently not available for the Spent-time report.


 
Some references to the related (duplicated) issues:

 
Maciej: Looking at your initial request you are looking to get the STCF data on the RedmineTimelogReport (AKA Spent-time report), which leads to the conclusion that this issue is a duplicate of #1692. Therefor I close this issue accordingly. Please reopen this issue elsewise...

#4 Updated by Maciej Czub almost 7 years ago

Everything becomes clear. Thank You for your support.

Also available in: Atom PDF