Defect #7213

Copy project does not copy all roles and permissions

Added by Chad Heuschober almost 7 years ago. Updated almost 7 years ago.

Status:ClosedStart date:2011-01-02
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Administration
Target version:1.1.0
Resolution:Fixed Affected version:1.0.2

Description

Hi,

I found a small defect in the copy project behavior. We're running a slightly older version (1.0.2), however I couldn't find any open or closed defect reports to this effect so I'm assuming it hasn't been fixed in a later version.

In my case, I have a user who is a member of a group with a low role (like reporter). This individual, however, has a high role in the project so he is also manually given a more permissive role (like Project Manager).

When I copy the project the user is reverted to the role he/she has as a member of the group and any special permissions are lost.

Since I use copy project to create projects from a template, it would be nice if this was fixed so our senior managers can have their permissions retained with each project.

Associated revisions

Revision 4615
Added by Jean-Philippe Lang almost 7 years ago

Additional roles of a user who belongs to a group are not always copied when copying the project (#7213).

History

#1 Updated by Jean-Philippe Lang almost 7 years ago

I'm not able to reproduce I was able to reproduce with latest trunk (or 1.1). Here are the steps I followed:
  • created a project
  • created a group with one user
  • added a role (A) to the group on the project
  • added an additional role (B) to the user on the project
  • copied the project
  • => the user has the 2 roles (A and B) on the new project only role A on the new project

#2 Updated by Jean-Philippe Lang almost 7 years ago

  • Status changed from New to Resolved
  • Target version set to 1.1.0
  • Resolution set to Fixed

Fixed in r4615. Thanks for pointing this out.

#3 Updated by Jean-Philippe Lang almost 7 years ago

  • Status changed from Resolved to Closed

Merged in 1.1-stable in r4617.

Also available in: Atom PDF