Defect #7515

Roadmap Version Time Tracking Error

Added by Mike Gilligan almost 7 years ago. Updated over 6 years ago.

Status:ClosedStart date:2011-02-01
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Roadmap
Target version:-
Resolution:Duplicate Affected version:1.1.0

Description

When viewing parent tasks (with subtasks), the estimated & spent hours reflected are those of the subtasks, which is what I would expect.

However, when I attach the parent task to a version (and only the parent task), the estimated & spent hours are 0, though the subtasks have time estimates and spent time.

For consistency, I believe the estimated & spent hours for the version, should reflect the totals for all tasks/subtasks.


Related issues

Duplicates Redmine - Defect #6422: timetracking: subtasks time is not added to the main task Closed 2010-09-17

History

#1 Updated by Mike Gilligan almost 7 years ago

Related to #6422

#2 Updated by Anton Nepomnyaschih over 6 years ago

+1 :)

It would be cool, if estimated time for version calculated as sum of all tickets that are assigned to the version. But without duplicated time (if some subtasks where summed to a parent task). In such case it worked in all 3 ways:
  1. if version would be assigned to all parent tasks and their subtasks
  2. if version would be assigned to only parent tasks, without their subtasks
  3. if version would be assigned to only subtasks, without their parent tasks ;)

#3 Updated by Etienne Massip over 6 years ago

Isn't it a duplicate of #6422 ?

#4 Updated by Anton Nepomnyaschih over 6 years ago

I think, it is =) I'll copy my comment with desirable algorithm there, if you don't mind =)

#5 Updated by Etienne Massip over 6 years ago

  • Status changed from New to Closed
  • Resolution set to Duplicate

Thanks, closed as duplicate of #6422.

Also available in: Atom PDF