Defect #7530

Error 500 while editing wiki pages if using Spanish locale

Added by David Marín Carreño over 6 years ago. Updated over 4 years ago.

Status:ClosedStart date:2011-02-03
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Translations
Target version:-
Resolution:Fixed Affected version:1.1.0

Description

I'm getting the following error while creating a wiki page, in both 1.1.0 and 1.1.1 versions:

I18n::MissingInterpolationArgument (missing interpolation argument in "Se ha añadido la página wiki '%{page}'." ({:id=>"Test"} given)):
  /usr/lib/ruby/gems/1.8/gems/i18n-0.4.2/lib/i18n/backend/base.rb:174:in `interpolate_without_deprecated_syntax'
  /usr/lib/ruby/gems/1.8/gems/i18n-0.4.2/lib/i18n/backend/base.rb:46:in `translate'
  /usr/lib/ruby/gems/1.8/gems/i18n-0.4.2/lib/i18n.rb:160:in `t'
  lib/redmine/i18n.rb:13:in `l'
  app/models/mailer.rb:182:in `wiki_content_added'
  app/models/wiki_content_observer.rb:20:in `after_create'
  /usr/lib/ruby/1.8/observer.rb:185:in `notify_observers'
  /usr/lib/ruby/1.8/observer.rb:184:in `each'
  /usr/lib/ruby/1.8/observer.rb:184:in `notify_observers'
  app/controllers/wiki_controller.rb:123:in `update'
  /opt/redmine/public/dispatch.fcgi:24

The problem is in Spanish translations file.

patch-redmine.txt Magnifier - Patch for es.yml file (736 Bytes) David Marín Carreño, 2011-02-03 15:19

History

#1 Updated by David Marín Carreño over 6 years ago

Attaching patch for fixing the problem in es.yml file.

#2 Updated by Filou Centrinov over 4 years ago

Already fixed. Issue can be closed.

#3 Updated by Etienne Massip over 4 years ago

Filou Centrinov wrote:

Already fixed. Issue can be closed.

Could you please provide some reference to the fixing revision/issue?

#5 Updated by Etienne Massip over 4 years ago

  • Status changed from New to Closed
  • Resolution set to Fixed

Ok, didn't get the true problem in the first place, sorry.

#6 Updated by Toshi MARUYAMA over 4 years ago

  • Category changed from I18n to Translations

Also available in: Atom PDF