Feature #7539

Rest-API limit of items not 100, but changeable by the administrator

Added by Guido Schweizer over 7 years ago. Updated over 2 years ago.

Status:ClosedStart date:2011-02-04
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:REST API
Target version:-
Resolution:Duplicate

Description

Instead of setting the limit to 100 hardcoded, the limit should be editable by the administrator.
Since the return object does send the server-side-limit, clients could react to a server-side change of the limit value.
In some cases the 100-limit causes a lot of calls to the api (server).


Related issues

Duplicates Redmine - Patch #16069: Allow configuration of API limit instead of hardcoding at... New

History

#1 Updated by Go MAEDA over 2 years ago

  • Status changed from New to Closed
  • Resolution set to Duplicate

Closing as a duplicate of #16069.

#2 Updated by Go MAEDA over 2 years ago

  • Duplicates Patch #16069: Allow configuration of API limit instead of hardcoding at 100 added

Also available in: Atom PDF