Defect #7630

Spent time in commits not recognized

Added by гиём шарьм almost 7 years ago. Updated over 6 years ago.

Status:ClosedStart date:2011-02-15
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Time tracking
Target version:1.1.2
Resolution:Fixed Affected version:

Description

Hello,

There is an issue with the time tracking thru commit :

I found nowhere on the website the correct syntax, I had to search around ticket with a lot of different syntax but it is finally Marek Siller (#4155) which gave me the correct one.

ref #123456 @2h30m

Except that this will add a time tracking of only 2h00min.

Then, is there any syntax for quotation or time log message?

Wouldn't it be nice to add some syntaxes like @2h or @2h30 ?

Also, the idea of Tomasz Sawicki was pretty good #4155#note-25. Is there any chance it will be implemented?

Best regards


Related issues

Related to Redmine - Feature #4155: Automatic spent time logging from commit messages Closed 2009-11-02
Duplicated by Redmine - Patch #7419: changeset.rb does not recognize time entries like @1h30m Closed 2011-01-24

Associated revisions

Revision 4951
Added by Jean-Philippe Lang over 6 years ago

Fixes syntax for time logging in commit messages (#7630, #7718).

History

#1 Updated by Marek Siller almost 7 years ago

Hello,

there is an issue with the regular expression (file app/models/changeset.rb), that checks for the spent time. I'm currently investigating where the problem is exactly and how to fix it. I'll post a patch as soon as I find the problem.

Sincerely,
Marek Siller
KTC - Karlsruhe Technology Consutling GmbH

#2 Updated by Jean-Philippe Lang over 6 years ago

  • Tracker changed from Feature to Defect
  • Subject changed from spent time on commit to Spent time in commits not recognized
  • Status changed from New to Resolved
  • Target version set to 1.1.2
  • Resolution set to Fixed

Syntax is fixed in r4951. @2h or @2h30 are now supported

#3 Updated by Jean-Philippe Lang over 6 years ago

  • Status changed from Resolved to Closed

Merged in 1.1-stable.

#4 Updated by Ho Tak over 6 years ago

Hello,

I have just setup the redmine, and in the administration -> settings -> Repositories, I tick the Enable time loggin.
But still, in the commit message, I have trying writing

refs #4 @2h

OR

refs #4 @2h30m

OR

refs #4 @2

OR

refs #4 @2.5

They all couldn't work, anything I still need to configure to make it work?

By the way, I am using gitolite, and the "refs #4" thing is successfully hook to the correct issue/project in redmine, I don't know wether this will help found out the problem.

Thanks a lot.

Tak.

#5 Updated by Ho Tak over 6 years ago

Ho Tak wrote:

Hello,

I have just setup the redmine, and in the administration -> settings -> Repositories, I tick the Enable time loggin.
But still, in the commit message, I have trying writing

refs #4 @2h

OR

refs #4 @2h30m

OR

refs #4 @2

OR

refs #4 @2.5

They all couldn't work, anything I still need to configure to make it work?

By the way, I am using gitolite, and the "refs #4" thing is successfully hook to the correct issue/project in redmine, I don't know wether this will help found out the problem.

Thanks a lot.

Tak.

Sorry for missing the redmine version, I am using Redmine 1.1.2.stable

Thanks.

Tak.

#6 Updated by Maciej Smoliński over 6 years ago

@Tak, this advice should solve your problem: http://www.redmine.org/boards/2/topics/22692?r=23334#message-23334

Maciej ;)

#7 Updated by Ho Tak over 6 years ago

Yes! This works!!!

I had discovered that I haven't change "Activity for logged time" to any one of them, stupid me.........

Thanks Maciej! ^^

Also available in: Atom PDF