Defect #7779

Error 500 when issue description is too long

Added by Jakob Fix almost 7 years ago. Updated almost 2 years ago.

Status:ClosedStart date:2011-03-04
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Issues
Target version:-
Resolution:Duplicate Affected version:1.1.1

Description

Apparently the length of the issue description (the field I'm typing into right now) is not checked and causes an Internal Error 500. Inserting around 150Kb of text (I know, not a good idea) triggered the error and we had to check the Redmine log to get a better idea of the cause of the error message.

If I understand correctly, the limit of the number of characters in the description field depends on the database field type which in MySql is 2^16 i.e. about 64Kb.

We're using 1.1.1 in a Windows environment with MySql.

Not sure Issues is the right category, or should it be Database?


Related issues

Duplicates Redmine - Defect #20127: The description column in the issues table is too short (... Closed

History

#1 Updated by Etienne Massip almost 7 years ago

PostgreSQL stores issue description in a column with text data type which length is unlimited, so adding a limit would be some kind of regression to PG users.

#2 Updated by Go MAEDA almost 2 years ago

  • Status changed from New to Closed
  • Resolution set to Duplicate

Closing as a duplicate of #20127.

#3 Updated by Go MAEDA almost 2 years ago

  • Duplicates Defect #20127: The description column in the issues table is too short (MySQL) added

Also available in: Atom PDF