Feature #7849

custom issue relation types

Added by Markus Valle-Klann about 7 years ago. Updated over 3 years ago.

Status:NewStart date:2011-03-13
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Issues
Target version:-
Resolution:

Description

In different projects I am using redmine with a number of custom trackers. To define relations between the tickets I would very much like to use other relations than the ones currently available.

For instance, we have trackers for requirements and features. And we would like to be able to define an "implements" relation: feature implements requirement.

The most sustainable solution would be to be able to define custom relation types much like custom fields. I searched for this on the redmine redmine but didn't find anything.

From looking at source:trunk/app/models/issue_relation.rb it seems fairly straightforward to factor out the relation types and define them like custom fields, including symmetry relationships between the types etc.

As we don't have any redmine development capabilities at the moment I hope more people would be interested to have that feature and somebody interested in implementing it :-) With some guidance and advise from experienced redmine developers my team might also be able to contribute to the development.


Related issues

Related to Redmine - Feature #13690: Allow plugins to be able to add relationship types New
Related to Redmine - Feature #15340: Custom field referencing other tickets New
Related to Redmine - Feature #16117: Add a new type of related issue: "exclusive" New
Related to Redmine - Feature #18034: related issue improvements Closed
Related to Redmine - Feature #25384: Add new issue relation type: Obsoletes and Obsoleted_by New
Related to Redmine - Feature #26786: Complex issue relation New
Related to Redmine - Feature #7629: Add "causes" and "caused by" issue relationships New 2011-02-15
Duplicated by Redmine - Feature #11276: Missing related issues "regressed" and "regressed by" (fo... Closed
Duplicated by Redmine - Defect #11311: New issue relationship Closed

History

#1 Updated by Johan Larsson about 6 years ago

+1
Would also like to add custom issue relation types.

#2 Updated by Laurent Dairaine about 6 years ago

+1

#3 Updated by Kelvin Chen over 5 years ago

+1
Would like to have this function as well :)

#4 Updated by Matt Andrews over 5 years ago

+1

#5 Updated by Adrián A. over 5 years ago

+1

#6 Updated by Mauro Chojrin over 5 years ago

+1. In my case, we use support tickets as QA tasks. It would be really helpfull to define relations such as "Tested in" (with simmetry in "Is tested by"). This feature combined with a custom workflow woudl definitely be a great improvement of my daily workflow.

#7 Updated by Fred Giusto over 5 years ago

+1
That's a very good idea

#8 Updated by Bo Hansen over 5 years ago

+1

#9 Updated by Tomas K over 5 years ago

+1

#10 Updated by Dipan Mehta about 5 years ago

+1. This one would be a great addition to many workflows.

#11 Updated by Lauren Copeland almost 5 years ago

+1 This feature would be useful.

#12 Updated by Brandon Liles almost 5 years ago

+1 Definitely agree. In our organization we assign review tickets for another developer to review our work. We currently use relations to track the review ticket in relation to the work ticket, but it would be nice to have a relationship type for this.

#13 Updated by Jeremy Thomerson almost 5 years ago

+1 I just found this as well and it would be great to be able to add symmetrical relation types either by plugins, or especially through the admin UI.

#14 Updated by Toshi MARUYAMA about 4 years ago

  • Related to Feature #15340: Custom field referencing other tickets added

#15 Updated by Mikhail Grinfeld about 4 years ago

+1

#16 Updated by Toshi MARUYAMA over 3 years ago

  • Description updated (diff)

#17 Updated by Toshi MARUYAMA over 3 years ago

  • Related to Feature #16117: Add a new type of related issue: "exclusive" added

#18 Updated by Toshi MARUYAMA over 3 years ago

#19 Updated by Toshi MARUYAMA about 1 year ago

  • Related to Feature #25384: Add new issue relation type: Obsoletes and Obsoleted_by added

#20 Updated by Toshi MARUYAMA 7 months ago

#21 Updated by Go MAEDA 27 days ago

  • Related to Feature #7629: Add "causes" and "caused by" issue relationships added

Also available in: Atom PDF