Defect #8207

Wiki concurrent editing - loosing my edit

Added by Vlad Vlad over 6 years ago. Updated over 6 years ago.

Status:ClosedStart date:2011-04-21
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Wiki
Target version:-
Resolution:Duplicate Affected version:

Description

If I open a wiki page and make changes and somebody else open the same page, edit it and save and then I try to save changes to an updated page it raises internal error that the page was changed. I can press back button but it reloads the current version and I loose all my edit.

The workaround is to press Ctrl+A, Ctrl+C before any save attempt in a wiki but I'm getting tired by it.

I just want that it would return me back to my edited text so I could do Ctrl+A, Ctrl+C, reload, chech changes, Ctrl+V, update, save. Not the best solution but easy to implement and would be enough for me as I would have to do it only when there is a collision not all the time.

Or at least make an option that it would copy the text to clipboard everytime when Save is pressed. This only thing starting to force me to switch to another system as it is quite anoing to loose a lot of text. Any chance to solve it?
Many thanks.


Related issues

Duplicates Redmine - Defect #7939: Simultaneous Wiki Updates Cause Internal Error Closed 2011-03-21

History

#1 Updated by Etienne Massip over 6 years ago

  • Status changed from New to Closed
  • Resolution set to Duplicate

Closed as duplicate of #7939 which fix has been committed and will be released with 1.13 or 1.20.

Also available in: Atom PDF