Defect #8291

Issued refed/closed by repository commit message don't show as associated revisions if issue is in a different project to the repository

Added by Declan Lynch over 6 years ago. Updated almost 5 years ago.

Status:ClosedStart date:2011-05-04
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:SCM
Target version:-
Resolution:Duplicate Affected version:

Description

We have a situation where we have a master project that has a repository associated with it and we then have a couple of sub-projects that don't have any repository associated with them.

Issues are raised at the sub-project level but the code is checked into the repository at the main project level.

When the committer uses the 'Refs #xx' or 'Fixes #xx' in the commit text the issue is marked as closed ( if using Fixes #xx ) as expected and the revision history shows the list of associated issues, However the issue itself does not show the 'Associated Revisions' block on the right side.

If the issue is at the same level as the project then the 'Associated Revisions' block shows up correctly. It is only when the issue is on a different project to the repository that the association does not show up.


Related issues

Related to Redmine - Defect #9762: Closing issues with commit should be cross project Closed
Duplicates Redmine - Defect #4674: Sub-project repository commits not displayed on parent pr... Closed 2010-01-28

History

#1 Updated by Jeffrey Clark over 6 years ago

Is the repository module enabled on the sub-project? It needs to be, even if it's not used/configured directly.

#2 Updated by Mischa The Evil almost 5 years ago

  • Status changed from New to Closed
  • Resolution set to Duplicate

This is actually a duplicate of #4674, which was implemented a long time ago for Redmine 0.9.2.
Closing as such.

Also available in: Atom PDF