Defect #8741

Git: diff is always empty in merged revsion

Added by Dave Abrahams over 6 years ago. Updated over 2 years ago.

Status:ClosedStart date:2011-07-03
Priority:LowDue date:
Assignee:-% Done:

0%

Category:SCM
Target version:-
Resolution:Duplicate Affected version:1.2.0

Description

A URL of the form https://hub.boostpro.com/projects/embt/repository/revisions/a74df08c89e1120f82c79619b32d657adb1d04f5 gets me a screen with the commit message, but not even a list of files. I have to append /diff to the URL to even find out that Redmine has decided not to show that detail because it's so large.

By the way, is there a place I can adjust that limit?

rev-url-short.diff Magnifier (730 Bytes) Toshi MARUYAMA, 2011-07-04 01:05

Screenshot-1.png (10.7 KB) Toshi MARUYAMA, 2011-07-04 01:12

Screenshot.png (13 KB) Toshi MARUYAMA, 2011-07-04 01:12


Related issues

Related to Redmine - Defect #7518: Mercurial diff can be wrong if the previous changeset isn... Closed 2011-02-02
Related to Redmine - Feature #3909: Mercurial: show repository graphic history Closed 2009-09-23
Duplicates Redmine - Defect #20693: GIT: No files/differences on git merge commit New

History

#1 Updated by Toshi MARUYAMA over 6 years ago

  • Tracker changed from Defect to Feature

#2 Updated by Toshi MARUYAMA over 6 years ago

  • Priority changed from Normal to Low

#3 Updated by Toshi MARUYAMA over 6 years ago

Try this patch.

#4 Updated by Toshi MARUYAMA over 6 years ago

  • Tracker changed from Feature to Defect

#5 Updated by Toshi MARUYAMA over 6 years ago

#6 Updated by Dave Abrahams over 6 years ago

  • Status changed from Closed to Reopened

I kept bumping those up until eventually the /diff URL stopped telling me that it was truncating the diffs, but still wouldn't show any diffs.

I think it's a defect (in both those pages) when you leave out information without explaining its absence. Just sayin'.

#7 Updated by Toshi MARUYAMA over 6 years ago

  • Status changed from Reopened to Closed
  • Resolution deleted (Invalid)

Git is DAG. Git has many parents. If merge revision has no changes, diff is empty.
For example,
https://www.chiliproject.org/projects/chiliproject/repository/revisions/9ce7fd42308ef462a667525bfb81e7def06038cc

#8 Updated by Toshi MARUYAMA over 6 years ago

  • Resolution set to Wont fix

#9 Updated by Toshi MARUYAMA over 6 years ago

  • Subject changed from Revision detail silently truncated to Git: Revision detail silently truncated

#10 Updated by Toshi MARUYAMA over 6 years ago

  • Subject changed from Git: Revision detail silently truncated to Git: diff detail silently truncated in merged revsion

#11 Updated by Toshi MARUYAMA over 6 years ago

  • Status changed from Closed to Reopened
  • Resolution deleted (Wont fix)

#12 Updated by Toshi MARUYAMA over 6 years ago

  • Subject changed from Git: diff detail silently truncated in merged revsion to Git: diff is empty in merged revsion

#13 Updated by Toshi MARUYAMA over 6 years ago

  • Subject changed from Git: diff is empty in merged revsion to Git: diff is always empty in merged revsion

#14 Updated by Dave Abrahams over 6 years ago

I believe the message from Redmine that the changes are too large to show conflicts with your theory that there are no changes to show.

#15 Updated by Toshi MARUYAMA over 6 years ago

I can't see https://hub.boostpro.com/projects/embt/repository/revisions/a74df08c89e1 ,
because this site uses self certified ssl.

#16 Updated by Dave Abrahams over 6 years ago

Toshi MARUYAMA wrote:

I can't see https://hub.boostpro.com/projects/embt/repository/revisions/a74df08c89e1 ,
because this site uses self certified ssl.

It's also password protected because it contains sensitive data, so even if you allowed the certificate, you wouldn't be able to see it. I'm doing my best with this bug report and if you would like some other kind of information, please tell me what it is.

#17 Updated by Toshi MARUYAMA over 2 years ago

  • Status changed from Reopened to Closed
  • Resolution set to Duplicate

I close as duplicate of #20693.
This issue is not smart.

#18 Updated by Toshi MARUYAMA over 2 years ago

  • Duplicates Defect #20693: GIT: No files/differences on git merge commit added

Also available in: Atom PDF