Defect #8935

Password reset is required before a user can login after upgrading from 0.9.1 to 1.2.1

Added by Matt H about 8 years ago. Updated over 6 years ago.

Status:ClosedStart date:2011-07-28
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:-
Target version:-
Resolution:Cant reproduce Affected version:

Description

Hi,

I've completed a test upgrade from 0.9.1 to 1.2.1 and found that users cannot login without first resetting their passwords.

This doesn't seem to be documented in the upgrade steps or in any bugs; is this to be expected?

[root@qaredmine redmine]# RAILS_ENV=production ruby script/about
Storing outgoing emails configuration in config/email.yml is deprecated. You should now store it in config/configuration.yml using the email_delivery setting.
About your application's environment
Ruby version              1.8.6 (i386-linux)
RubyGems version          1.3.7
Rack version              1.1.1
Rails version             2.3.11
Active Record version     2.3.11
Active Resource version   2.3.11
Action Mailer version     2.3.11
Active Support version    2.3.11
Edge Rails revision       unknown
Application root          /opt/redmine-1.2.1
Environment               production
Database adapter          mysql
Database schema version   20110511000000

History

#1 Updated by Jean-Philippe Lang about 8 years ago

  • Resolution set to Cant reproduce

Can not reproduce. Upgrade from 0.9.1 to 1.2.1 should not require password reset.

#2 Updated by Matt H about 8 years ago

On further investigation, I discovered it was because I installed Rails: gem install rails -v=2.3.11

If I don't manually install Rails, the password does not need resetting.

#3 Updated by Daniel Felix over 6 years ago

  • Status changed from New to Closed

This one could be closed.

The issue is fairly outdated. The affected versions weren't supported anymore.

The author itself says that this issue is fixed by himself.

Also available in: Atom PDF