Defect #9064

Broken internal links in export wiki to html

Added by Andrey Shevchenko about 6 years ago. Updated about 6 years ago.

Status:ClosedStart date:2011-08-16
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Wiki
Target version:-
Resolution:Duplicate Affected version:1.2.0

Description

Example:

page "Test"

h1. Test

(see [[Test#Configuration|configuration]])

h2. Configuration

To configure view use these methods:

Export to HTML:

<h1 >Test<a href="#Test" class="wiki-anchor">&para;</a></h1>

    <p>(see <a href="configuration.html" class="wiki-page">configuration</a>)</p>

    <a name="Configuration"></a>
<h2 >Configuration<a href="#Configuration" class="wiki-anchor">&para;</a></h2>

    <p>To configure view use these methods:</p>

But expected result should contain

<a href="#Configuration" class="wiki-page">

instead of

<a href="configuration.html" class="wiki-page">


Related issues

Duplicates Redmine - Defect #3276: Incorrect handling of anchors in Wiki to HTML export Closed 2009-04-30

History

#1 Updated by Etienne Massip about 6 years ago

  • Target version set to Candidate for next minor release

Indeed.

#2 Updated by Etienne Massip about 6 years ago

  • Status changed from New to Closed
  • Target version deleted (Candidate for next minor release)
  • Resolution set to Duplicate

Closed as duplicate of #3276.

Also available in: Atom PDF