Defect #9108

Custom query not saving status filter

Added by Cassiano Monteiro about 6 years ago. Updated almost 6 years ago.

Status:ClosedStart date:2011-08-23
Priority:NormalDue date:
Assignee:Etienne Massip% Done:

0%

Category:Issues
Target version:1.3.0
Resolution:Fixed Affected version:1.2.1

Description

When creating a custom query, its default is to save the Status filter to "open", disregarding whether I disable it to get all statuses. In order to create this custom query properly, I have to save it, and after that change the status filter again.

To reproduce:

1. Go to issues list and click "Save" to create a custom query.
2. Uncheck the "Status" filter, so it would show all statuses, and save the query.
3. Note that the query is STILL showing only issues with status "Open".
4. Edit the custom query and uncheck the "Status" filter again.
5. Note that the query is now showing all issues correctly, with no status filter.

I think that the expected behavior would save the unchecked "Status" filter on the first try.

My version is 1.1.1, but this also happened on the online demo.


Related issues

Related to Redmine - Defect #9738: Setting of cross-project custom query is not remembered i... Closed

Associated revisions

Revision 7649
Added by Etienne Massip about 6 years ago

Refactor : convert queries to REST resources (also fixes #9108).

Revision 7656
Added by Etienne Massip about 6 years ago

Reverted removal of project assignment to query (#9108).

Revision 7657
Added by Etienne Massip about 6 years ago

Make queries resources fully conform to common behavior (removed additonal routes) (#9108).

Revision 7826
Added by Etienne Massip about 6 years ago

Updated permissions with newly added create and update actions (#9108).

History

#1 Updated by Etienne Massip about 6 years ago

  • Target version set to Candidate for next minor release
  • Affected version (unused) changed from 1.1.1 to 1.2.1
  • Affected version changed from 1.1.1 to 1.2.1

Indeed, in the New query screen, RM lists the Status field even if this one was unchecked.

Even if you can uncheck it again from this screen before you save the query, this does not happen to other fields, hence the bug.

Kind of same issue as #8411, I guess.

#2 Updated by Etienne Massip about 6 years ago

  • Status changed from New to Resolved
  • Target version changed from Candidate for next minor release to 1.3.0
  • Resolution set to Fixed

Should be fixed with r7649 which is too big to be included in a minor release.

#3 Updated by Etienne Massip about 6 years ago

  • Status changed from Resolved to 7
  • Assignee set to Etienne Massip
  • Resolution deleted (Fixed)

Ok, there is a big bug now with handling project, will fix it tonight.

#4 Updated by Etienne Massip about 6 years ago

  • Status changed from 7 to Resolved
  • Resolution set to Fixed

Should be clean now with r7657.

#5 Updated by Mischa The Evil about 6 years ago

Etienne Massip wrote:

Should be clean now with r7657.

Confirmed!

#6 Updated by Etienne Massip about 6 years ago

Mischa The Evil wrote:

Confirmed!

Thanks. So glad to see you here again, Mischa =)

#7 Updated by Etienne Massip about 6 years ago

  • Status changed from Resolved to 7

Something must have gone wrong: Issue filter problem.

#8 Updated by Etienne Massip about 6 years ago

  • Status changed from 7 to Resolved

Etienne Massip wrote:

Something must have gone wrong: Issue filter problem.

Finally, seems to be only plugin issues.

#9 Updated by Etienne Massip about 6 years ago

  • Status changed from Resolved to 7

There might be some remaining Queries permissions work to go in source:/trunk/lib/redmine.rb@7819#L81.

#10 Updated by Etienne Massip about 6 years ago

  • Status changed from 7 to Closed

#11 Updated by Etienne Massip almost 6 years ago

  • Status changed from Closed to Reopened
  • Resolution deleted (Fixed)

Still not fixed according to #9738.

#12 Updated by Jean-Philippe Lang almost 6 years ago

  • Status changed from Reopened to Closed
  • Resolution set to Fixed

Not related to #9738 and it can not be reproduced.

#13 Updated by Etienne Massip almost 6 years ago

#9738 has appeared after the query refactoring committed for this issue.

Also available in: Atom PDF