Defect #9253

Workflow copy does not copy advanced workflow settings anymore in 1.2.1

Added by pasquale [:dedalus] about 6 years ago. Updated about 6 years ago.

Status:ClosedStart date:2011-09-15
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Administration
Target version:-
Resolution:Invalid Affected version:1.2.1

Description

Issue #8739 isn't being fixed with in 1.2.1:

STR (steps to reproduce with 1.2.1 stable):
1. new role;
2. copy workflow from an existing role and create it;
3. see the new role created: no checks are flagged in permission report

follow bug #8739

bug-in-action.png (32.3 KB) pasquale [:dedalus], 2011-09-15 17:40


Related issues

Related to Redmine - Defect #8739: Workflow copy does not copy advanced workflow settings Closed 2011-07-02

History

#1 Updated by Etienne Massip about 6 years ago

  • Assignee deleted (Jean-Philippe Lang)

Please do not assign issues.

#2 Updated by Etienne Massip about 6 years ago

Can't reproduce?

Could this be a plugin interference?

#3 Updated by pasquale [:dedalus] about 6 years ago

Etienne Massip wrote:

Could this be a plugin interference?

No, I have test this behavior with a fresh clean install of 1.2.1 stable release and the issue is still here

#4 Updated by Etienne Massip about 6 years ago

So you didn't change any of the existing workflow before doing the test?

What role did you pick for workflow copying when creating the new role?

#5 Updated by pasquale [:dedalus] about 6 years ago

I have create a new role based on existing one "Developer"

#6 Updated by Etienne Massip about 6 years ago

Can you paste here the WF "Summary" screenshot please?

#7 Updated by pasquale [:dedalus] about 6 years ago

Etienne Massip wrote:

Can you paste here the WF "Summary" screenshot please?

bug-in-action.png

#8 Updated by Etienne Massip about 6 years ago

  • Status changed from New to Closed
  • Resolution set to Invalid

Sorry, I misread in the first time: you said no checks are flagged in permission report

I thought you were actually talking about the states & transitions per role per tracker, what is usually called workflow but...permissions are not part of a workflow and I don't think there has ever been such a feature in Redmine.

Surprisingly, I didn't find any Role copy feature request in issues database, so you might want to open a new one.

#9 Updated by Etienne Massip about 6 years ago

I did : #9258.

Also available in: Atom PDF