Feature #9292

"Data has been updated by another user." - Allow this to be clicked through

Added by matthew matthew about 6 years ago. Updated over 5 years ago.

Status:ClosedStart date:2011-09-21
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Issues
Target version:-
Resolution:Duplicate

Description

"Data has been updated by another user."

This error message is presented whenever you make an update to a ticket which has been updated by another user. When this occurs all of the comments on the issue are hidden and just your attempted submission is shown. You can resubmit it, but you will continue to receive the error message.

It seriously sucks. Instead of the current behaviour, you should show the new updates in some highlighted fashion, alert the user, and then allow them to submit their update anyway (perhaps with a confirmation).

What do you really expect this work-blocking alert to achieve? If you have spent some time working on the update it can easily be lost (like by force reloading the page, which is required to actually submit an update). Intentionally hiding the updated comments also seems contrary to any goal of this alert - like if someone submitted the same update you would not see it, and after force reloading you may well skip it.


Related issues

Duplicates Redmine - Feature #8691: Better handling of issue update conflict Closed 2011-06-27

History

#1 Updated by matthew matthew about 6 years ago

test

#2 Updated by matthew matthew about 6 years ago

another test

#3 Updated by matthew matthew about 6 years ago

In order to reproduce this issue I think the update needs to be performed by another user.

#4 Updated by Etienne Massip about 6 years ago

  • Category set to Issues

#5 Updated by Nayuta Taga about 6 years ago

I think this issue is very serious problem, too.

#6 Updated by Etienne Massip about 6 years ago

  • Target version set to Candidate for next major release

#7 Updated by TridenT Job about 6 years ago

No issue when only adding comments in update (no change to properties / status).

#8 Updated by matthew matthew about 6 years ago

As I mentioned in my comment I believe the issue is most easily reproduced with two user accounts. This happens to me most when my boss comments on or otherwise alters a ticket that I am working on, or when a git post commit hook adds data to a ticket.

#9 Updated by pasquale [:dedalus] about 6 years ago

This is a duplicate of bug #8691

#10 Updated by Etienne Massip about 6 years ago

  • Status changed from New to Closed
  • Target version deleted (Candidate for next major release)
  • Resolution set to Duplicate

Indeed, closed as such.

#11 Updated by Nayuta Taga almost 6 years ago

Patches for this issue are available in #8691

Also available in: Atom PDF