Feature #944

Oracle Support in Redmine

Added by Mario Haupt over 6 years ago. Updated almost 2 years ago.

Status:ClosedStart date:2008-03-28
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:-
Target version:-
Resolution:

Description

Hello @redmine-team,

I started evaluation off redmine. I'm very impressed. It seem's to be very usefull for our work.
We are very familar with Oracle-RDMBS.

Oracle is currently not supported, but SQL-Scripts are included in installation.
Some problems are related to rails Framework and not to redmine.

Are there any plans to support Oracle-RDMBS?

Best regards

Mario Haupt


Related issues

Related to Defect #49: Creation of Schema in Oracle Closed
Related to Defect #921: NoMethodError in IssuesController on Oracle Closed 2008-03-24
Related to Defect #922: NoMethodError in MyController#account using Oracle Closed 2008-03-24
Related to Defect #920: Welcome page fails (login problem) on new Oracle install Closed 2008-03-24
Related to Feature #2272: Redmine on Oracle Database - Windows Installation Resolved 2008-12-03
Related to Defect #6472: "Gantt" doesn't work with oracle database Closed 2010-09-23
Related to Defect #7825: open_id_authentication_associations table name too long f... New 2011-03-10
Related to Defect #7826: bigdecimal-segfault-fix.rb must be removed for Oracle Closed 2011-03-10
Related to Patch #2383: Redmine, glassfish and Oracle working! Closed 2008-12-23
Related to Patch #6469: "Activity" doesn't work with oracle database New 2010-09-23
Related to Defect #10136: Error rake db:migrate in BuildsProjectsTree Closed
Related to Patch #11721: Oracle support in Redmine 1.4.4 Closed
Duplicated by Feature #9191: Redmine on Oracle Closed 2011-09-06

History

#1 Updated by Thomas Lecavelier over 6 years ago

  • Status changed from New to Closed

Not a defect. There's forum for this kind of discussions. Oracle is working, but not officially supported as we don't have enough people testing with Oracle.

http://www.redmine.org/projects/redmine/boards

#2 Updated by Etienne Massip almost 3 years ago

  • Subject changed from Oracle Support in Redmine? to Oracle Support in Redmine

#4 Updated by sinco miao over 2 years ago

--

#5 Updated by Juan G almost 2 years ago

I have upgraded from 1.2.0 to 1.4.4 succesfully. Someone want the patch? It works with my current Oracle installation.

#6 Updated by Etienne Massip almost 2 years ago

Juan G wrote:

I have upgraded from 1.2.0 to 1.4.4 succesfully. Someone want the patch? It works with my current Oracle installation.

Yes, if you could post it it could be helpful, thanks.

#7 Updated by Juan G almost 2 years ago

I've created this issue with attached patch: #11721

Feel free to comment any issues you have with this.

Also available in: Atom PDF