Defect #9551

Changing assignee should be notify the previous assignee

Added by pasquale [:dedalus] almost 6 years ago. Updated about 5 years ago.

Status:ClosedStart date:2011-11-11
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Issues
Target version:-
Resolution: Affected version:1.2.1

Description

When user change assignee to a new developer, the old assignee should be notify by mail (making this for example adding the old assignee as watcher).

I intend this as a defect and not feature, because if the old assignee is working to bug resolution and a new one change assignee, 2 different person can work to same problem.


Related issues

Duplicates Redmine - Feature #2694: Notification on loosing assignment Closed 2009-02-07

History

#1 Updated by Mischa The Evil almost 6 years ago

  • Status changed from New to Closed
  • Priority changed from High to Normal
  • Resolution set to Invalid

pasquale [:dedalus] wrote:

When user change assignee to a new developer, the old assignee should be notify by mail

Depending on the email settings of both Redmine in general and the involved Redmine users specifically, email notifications are already sent to the involved users whenever the Assignee attribute value of the issue changes.

I intend this as a defect and not feature, because if the old assignee is working to bug resolution and a new one change assignee, 2 different person can work to same problem.

See above...

#2 Updated by pasquale [:dedalus] almost 6 years ago

  • Status changed from Closed to Reopened

Depending on the email settings of both Redmine in general and the involved Redmine users specifically

Misha you are wrong.

I want that when I'm assignee of the bug and someone change assignee (in one of my project where I'm not watcher), Redmine notify me by mail. This now can't happens when I have set my notification as "Only for things I watch or I'm involveed in".

=> Reopen

#3 Updated by Jean-Philippe Lang almost 6 years ago

  • Status changed from Reopened to Confirmed
  • Resolution deleted (Invalid)

Indeed. Say we have 2 users A and B who want notifications for assigned issue.
When the assignee of an issue is changed from A to B, only B gets notified. A should be notified of the change.

#4 Updated by Mischa The Evil almost 6 years ago

Jean-Philippe Lang wrote:

Indeed.

That is also what I found out while I was testing it with the additional info provided in note-2, but still had to post my "results" to this issue... :-/

pasquale [:dedalus]

This now can't happens when I have set my notification as "Only for things I watch or I'm involveed in".

What I saw was that this is not tied to the users mail notification setting. This e.g. also happens when the settings value is "Only for things that I am assigned to".

#5 Updated by Mischa The Evil almost 6 years ago

FTR, this was first reported in #2694.

#6 Updated by Jean-Philippe Lang over 5 years ago

  • Status changed from Confirmed to Closed

Implemented in r8695.

#7 Updated by pasquale [:dedalus] over 5 years ago

Jean-Philippe Lang wrote:

Implemented in r8695.

Great! Missing target version (1.3.1 or 1.4.0)

#8 Updated by Etienne Massip over 5 years ago

  • Target version set to 1.4.0

#9 Updated by Etienne Massip over 5 years ago

  • Target version deleted (1.4.0)

My bad, it has already been set to 1.4.0 in #2694.

#10 Updated by jie zheng about 5 years ago

hi, it seems can not work. I test with my account and account B, when change the issue assignee from me to B, B can receive mail but i can not receive the mail. what's happened?

Also available in: Atom PDF