Feature #9700

Allow to configure the visibility of the fields of the “New issue” form per role

Added by Hugues De Keyzer almost 6 years ago. Updated almost 6 years ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Issues
Target version:-
Resolution:Duplicate

Description

All fields of the “New issue” form are visible to every role. This is not ideal, as a reporter can enter values that normally only a manager or a developer should enter, such as assignee, start and due date, estimated time,… Moreover, it unnecessarily complicates the form for less technical users.

It would be nice to be able to configure the visibility of the fields of this form per role. If configuring the visibility of each field is not feasible, a possibility would be to have a permission to set values for the “advanced” fields. I consider that the basic fields that should always be displayed are:
  • Tracker
  • Subject
  • Description
  • Files (to allow to join screenshots etc.)

All other fields should not be displayed in the form if the user doesn’t have the permission to set them. It should be possible to configure whether custom fields are “basic” or “advanced”.


Related issues

Related to Redmine - Feature #1091: Disabling default ticket fields per tracker Closed 2008-04-23
Related to Redmine - Feature #8050: Mightful workflow field enhancement: visible, read only ... Closed 2011-04-03
Duplicates Redmine - Feature #5011: Limit Visible Issue Fields Based on Permissions Closed 2010-03-08

History

#1 Updated by Etienne Massip almost 6 years ago

  • Category set to Issues

It's a duplicate of some existing issue.

#2 Updated by Hugues De Keyzer almost 6 years ago

Etienne Massip wrote:

It's a duplicate of some existing issue.

Issue #1091 is related, but different, as it is about disabling default fields per tracker, not per role.

#3 Updated by Mischa The Evil almost 6 years ago

Added relations to #1091 and #8050.

#4 Updated by pasquale [:dedalus] almost 6 years ago

  • Status changed from New to Resolved

it's a dupe of bug #5011

#5 Updated by pasquale [:dedalus] almost 6 years ago

ps: I can't set resolution=> duplicate (I haven't the permission)

#6 Updated by Etienne Massip almost 6 years ago

  • Status changed from Resolved to Closed
  • Resolution set to Duplicate

Closed as duplicate of #5037.

#7 Updated by Hugues De Keyzer almost 6 years ago

Etienne Massip wrote:

Closed as duplicate of #5037.

#5037 is about custom fields only. This is a duplicate of #5011, as pasquale [:dedalus] noted.

#8 Updated by Etienne Massip almost 6 years ago

Hugues De Keyzer wrote:

Etienne Massip wrote:

Closed as duplicate of #5037.

#5037 is about custom fields only. This is a duplicate of #5011, as pasquale [:dedalus] noted.

#5037 original topic was about all types of fields and roles, and #5011 was not referring explicitly to roles, that's why I set #5037 as duplicate. Anyway, if you prefer =)

Also available in: Atom PDF