Feature #9702

Have a changelog

Added by Hugues De Keyzer over 7 years ago. Updated over 7 years ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Roadmap
Target version:-
Resolution:Duplicate

Description

The list of past changes can be accessed through the roadmap, but having a default changelog URL (even if it is not in the primary links) that shows only completed versions (with pagination) would seem more intuitive. A roadmap is more commonly used to look into the future only.


Related issues

Duplicates Redmine - Feature #7043: Give user ability to generate changelogs New 2010-12-04

History

#1 Updated by Etienne Massip over 7 years ago

  • Category set to Roadmap

From a personal POV, I can't see any value added to have a specific changelog page since the roadmap seems pretty easy to read?

#2 Updated by Hugues De Keyzer over 7 years ago

Etienne Massip wrote:

From a personal POV, I can't see any value added to have a specific changelog page since the roadmap seems pretty easy to read?

It would really be more a convenience. Users new to Redmine searching for a changelog will probably not look into the roadmap.

Also, it is not possible to display only the closed versions on the roadmap, which seems logical for a roadmap, but a changelog usually starts with the latest release, not the versions that are in development.

Moreover, when selecting the “Show completed versions” in the roadmap, it shows all versions on one page, which takes time to load and results in a very long page.

I’m thinking about something like the manually created Changelog. If it exists and is updated, it means it has its uses, don’t you think? ;)

#3 Updated by Mischa The Evil over 7 years ago

  • Status changed from New to Closed
  • Resolution set to Duplicate

Closed as a duplicate of #7043. That one seems to cover this issue the most.

FYI: there once was a dedicated changelog view. It was removed from the core with r3162 as part of #2972. As mentioned in #2972 .note-4 Eric Davis has ported the old Changelog view to a plugin in response.

Also available in: Atom PDF