Defect #9742

Issues from other projects appearing in an specific project

Added by Bruno Medeiros about 6 years ago. Updated about 6 years ago.

Status:ClosedStart date:
Priority:HighDue date:
Assignee:-% Done:

0%

Category:-
Target version:-
Resolution:Duplicate Affected version:

Description

I've just migrated to the 1.3-stable branch (Redmine 1.3.0.stable.8106 (MySQL)) and I'm experiencing the following issue: I can see issues from other projects inside a project if I change the tab from Gantt to Issues, but select a custom query before change. The tab switches ok, but the result is not filtered by project.

The following steps reproduce the problem.

  • Create a custom query that matches tickets in more than one project (Mine is: status=open, assignee=<me>, %done<=90)
  • Make sure to have issues that matches your query in more than one project, and make sure to fill the dates to allow this issues to appear in gantt.
  • Open the issues tab inside one of the projects
  • Click 'show all issues' in case you have a custom query selected
  • Click your custom query
  • Change to Gantt tab
  • You should see issues for other projects inside the gantt

You can reproduce going in Gantt first, just change the order of tabs visit and clear any custom query using 'show all issues' before start.

It seems that redmine forgets the current project when the tab is changed. If you click 'apply' or reselect the custom query the problem does not occur again.

I'm puttinf devel as affected version because I couldn't reproduce on demo.redmine.org, so I'm assuming that it's specific to 1.3.

Following my environment:

Ruby version 1.8.6 (x86_64-linux)
RubyGems version 1.3.7
Rack version 1.1
Rails version 2.3.14
Active Record version 2.3.14
Active Resource version 2.3.14
Action Mailer version 2.3.14
Active Support version 2.3.14
Application root /opt/redmine/redmine-1.3
Environment production
Database adapter mysql
Database schema version 20110902000000


Related issues

Duplicates Redmine - Defect #9738: Setting of cross-project custom query is not remembered i... Closed

History

#1 Updated by Bruno Medeiros about 6 years ago

I think it's related to #9738, even duplicates it. This is a little different bug, but I think solution will be the same.

#2 Updated by Jean-Philippe Lang about 6 years ago

  • Status changed from New to Closed
  • Resolution set to Duplicate

Indeed, it's the same. Fixed in r8113.

Also available in: Atom PDF