Feature #991

Document versioning

Added by Steve V over 9 years ago. Updated over 3 years ago.

Status:NewStart date:2008-04-04
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Documents
Target version:-
Resolution:

Description

I thought Redmine previously did this, but I might be mistaken... It would be great if there was a way to upload a new version of a document, and still retain the old one. Just sequential numbering, with upload timestamp, and uploading user would probably be fine. Maybe a comment field to allow description of what changed from the previous version. Redmine does so much else for project management so well, this would definitely be another great feature. If it's already there and I'm just missing it, please let me know.


Related issues

Related to Redmine - Feature #3995: Upgrade to "Files" module New 2009-10-08
Related to Redmine - Feature #1196: Add versioning for Files and Documents New 2008-05-07
Duplicated by Redmine - Feature #800: Enable versioning for Documents and Files modules Closed 2008-03-06
Duplicated by Redmine - Feature #736: documents - directories and versions New 2008-02-25
Duplicated by Redmine - Feature #2555: Possibility for update Documents - version control Closed 2009-01-21

History

#1 Updated by Jos Yule over 9 years ago

I had a similar request in (issue #800 - i've set its status to "resolved") but this is more straight-forward and, hopefully, implementable.

#2 Updated by Thomas Lecavelier over 9 years ago

  • Status changed from New to Closed

Closed as duplicated of #991 at reporter request.

#3 Updated by Thomas Lecavelier over 9 years ago

  • Status changed from Closed to Reopened

(I'm a baka... forgot that duplicated issue are linked)

#4 Updated by Michael Aye almost 9 years ago

+1

#5 Updated by Andreas Huggel over 8 years ago

+1

#6 Updated by William Bush over 8 years ago

+1

#7 Updated by Klas Germunder about 8 years ago

Any thing new in this issue?

#8 Updated by Dario Laera about 8 years ago

+1

#9 Updated by Andreas Huggel almost 8 years ago

+1

#10 Updated by Richard Hurt over 7 years ago

+1

My teammates and I were just discussing this feature in a hallway meeting. Is there any strategy at all for dealing with versioned documents?

#11 Updated by julien brule over 7 years ago

+1

#12 Updated by Alvaro Herrera over 7 years ago

I've been recently converting some Wiki pages to Documents, but this lack of version control makes me question whether this is really a good choice. So +1 for some sort of versioning strategy for documents.

#13 Updated by Dylan Yee about 7 years ago

+1
I have been looking for a project management system that can include simple document management with versioning. So far sharepoint did that but I just dont like sharepoint. If redmine could implement this my organization would have accept redmine.
Also, If wiki can be used as documentation would be a real great function, and as Alvaro suggested, adding versioning to wiki will be very helpful

#14 Updated by Terence Mill about 7 years ago

Just also have a look at a similar discussion in Forum.

Beyond the ui discussion, can you use a common and established scm or other dms service to save and handle the versioning and metadata handling around the files?
Most people won't like to save their file and history to new kind of system. The task "versioning of files" is already done and there are enough good standars to use or build on.

Some thinking and ideas..
In our case we use as scm Subversion and advanced integration via webdav. The problem is that we would need a business analyst compatible frontend for uploading (crud), versioning, watching changes and managing project documentation beyond code (there our coders use svn clients on svn server behind redmine).

You could use the standard scm configured in project archiv or embedd a defined one for saving the versions of files and docs.

In the case of using svn with adavanced redmine integration, you already have webdav on svn. Now you "only" need a nice frontend so some special folders on svn repo where you manage the docs and files for your project.

#15 Updated by Aaron Boxer about 7 years ago

+1
This would be a killer feature for us. I just introduced Redmine primarily to track dev issues, but we are beginning to use more of its project management features. Lack of versioning is a big problem; we need an audit
trail of who changes documents, and some users are not tech-savvy in using another SCM system for documents.
I will have to set up a second wiki, such as FOSWIKI, which does versioning, and link to Redmine, but it would be much simpler to not have to do this.

#16 Updated by Aleksandar Pavic about 7 years ago

+1 ppl in my company cries over it...

#17 Updated by Felix Schäfer about 7 years ago

Aleksandar Pavic wrote:

+1 ppl in my company cries over it…

You could also use SVN, which is intended for such purposes, you know?…

#18 Updated by Aleksandar Pavic about 7 years ago

What Steve V, and Aaron Boxer explained with this feature request is what I exactly need.

I can't make non-tech people use & install SVN.
They just get URL to redmine with username/password and use it for collaboration on tasks & documents
on marketing projects.

Additional + would be to see all files ever uploaded on issues in files module, like #3995

#19 Updated by Dario Laera about 7 years ago

Aleksandar Pavic wrote:

What Steve V, and Aaron Boxer explained with this feature request is what I exactly need.

I can't make non-tech people use & install SVN.
They just get URL to redmine with username/password and use it for collaboration on tasks & documents
on marketing projects.

I agree. Probably the ideal solution is to have the documentation module using a repo as back end for storing and versioning files, and providing a simple interface similar to the actual one as front end.

#20 Updated by Pedro Gutierrez about 7 years ago

I agree. Probably the ideal solution is to have the documentation module using a repo as back end for storing and versioning files, and providing a simple interface similar to the actual one as front end.

Sure, I also agree that SVN is not the best option for non-technical people

#3071 addresses this topic of providing an external repository for storing and versioning such as Alfresco. But, so far, I've seen no progress.

Dealing with documents much easier, however, can be done through existing plugins such as #801. My colleague Xabier has been uploading changes these days to improve this plugin developed by Arnaud. I recomend it.

#21 Updated by Karel Pičman over 6 years ago

Try a new DMSF plugin here http://www.redmine.org/plugins/dmsf. The plugin implements basic DMS features such as versioning, folder structure, multi upload, workflow,...

#22 Updated by Toshi MARUYAMA over 3 years ago

  • Related to deleted (Feature #2555: Possibility for update Documents - version control )

#23 Updated by Toshi MARUYAMA over 3 years ago

  • Duplicated by Feature #2555: Possibility for update Documents - version control added

#24 Updated by Toshi MARUYAMA over 3 years ago

#25 Updated by Toshi MARUYAMA over 3 years ago

  • Related to Feature #1196: Add versioning for Files and Documents added

#26 Updated by Toshi MARUYAMA over 3 years ago

  • Status changed from Reopened to New

Also available in: Atom PDF