Defect #9999

opening a new session when already logged, cause an error

Added by Jérôme BATAILLE almost 6 years ago. Updated almost 5 years ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Accounts / authentication
Target version:-
Resolution:Cant reproduce Affected version:

Description

This case happens when multiple redmine are opened in different tabs and that we want to relog without disconnecting

BUG FIX :
do not destroy a session that is already empty

NoMethodError (undefined method `destroy' for {}:Hash):
app/controllers/application_controller.rb:92:in `logged_user='
app/controllers/account_controller.rb:203:in `successful_authentication'

fix_double_open_session.diff Magnifier (481 Bytes) Jérôme BATAILLE, 2012-01-16 12:12

History

#1 Updated by Jean-Philippe Lang over 5 years ago

I can't reproduce. Can you describe the steps to follow in order to reproduce?

#2 Updated by Jean-Philippe Lang over 5 years ago

  • Resolution changed from Fixed to Cant reproduce

#3 Updated by Jean-Baptiste Barth over 5 years ago

  • Status changed from New to Closed

Me neither, on 2.0.2-stable logging multiple times in different tabs works without any error. I close the issue, please re-open it with more informations if you feel so (see SubmittingBugs).

#4 Updated by Redmine Smile almost 5 years ago

This patch is usefull for Redmine 1.2.1, but it seems to have been fixed in more recent versions.

Linked to #7857

To reproduce :
Login as one user, and the re-login with another one.

#5 Updated by Daniel Felix almost 5 years ago

Redmine Smile wrote:

This patch is usefull for Redmine 1.2.1, but it seems to have been fixed in more recent versions.

This means you won't be able to reproduce it in 2.2.1 or 1.4.6?

If this is fixed in these versions, we could close this issue.

#6 Updated by Redmine Smile almost 5 years ago

This means you won't be able to reproduce it in 2.2.1 or 1.4.6?

I just tested on Redmine.org, not reproduced.
Tested too on a Redmine V2.1.4 not reproduced too.

So I suppose we can close this bug.

Also available in: Atom PDF