Feature #20603

Updated by Etienne Massip over 2 years ago

It would allow Redmine to be compatible with SQL Server 2005 to 2008R2 until Rails 5 makes his way out and Rail 4.1 branch gets unmaintained.

*<copy/paste from #14534#note-46 >*

As Toshi noticed (message#45925) they chose to break compatibility with @MSSQL@ < 2012 which is a bit brutal.

Specifying Rails ~> 4.1 in Gemfile seems to do the trick with trunk @ r14520, do you know if some of the changes that were made when switching from 4.1 to 4.2 aren't 4.1 compatible?

*</copy/paste>*

I don't think there are plans for using Rails 4.2 features, any idea?

Back